[4.3] Can't fullscreen or set standalone resolution

I’ve seen several other unanswered instances of this exact issue - full screening a standalone game causes it to minimise and be unrecoverable - you have to delete your packaged game and repackage it in order to play in standalone mode again.

Also, the game won’t use the resolution specified under the standalone project play settings. I’m not sure if this is meant to control the standalone build resolution but it’s the only place I’ve been able to locate it.

Any idea how I can fix this?

Hi Antidamage,

I assigned a support technician to this post. I see that it is marked with a “Crash” tag, but your report does not mention a crash specifically. If you are receiving a crash, please post your callstack and log file as well if you can. That will help us with this investigation.

Thank you,

Alexander

DXDiag: MEGA

Crash is probably the wrong term, sorry. The icon is still there, it just can’t be accessed. It hasn’t hung but it won’t fullscreen or display again.

Here’s a copy of the standalone build that refuses to run. My desktop is running in 1920x1080 and has a secondary screen of 1200x1024, which may be relevant: MEGA

Hi Antidamage,

Due to our company firewall, I am unable to access that website, please upload the files to an ftp server such as dropbox. Does this happen in a clean project with no additional content? Thank you!

No problem!

I have also built a fresh FirstPersonShooter content example and it has the same problem. Probably something in my global settings - can you possibly suggest what it might be?

Hi antidamage,

Unfortunately thus far I have been unable to reproduce this. What method are you using to go into fullscreen mode?

I’m fullscreening by pressing alt-enter. It sounds like the other person experiencing this was entering fullscreen in the same way.

Just to confirm - you’ve downloaded the zip file above, extracted it, run the game in a dual-screen environment (1920x1080 and 1200x1024) and hit alt-enter and it’s successfully gone into full screen and displayed the game?

It’ll be good if it’s only happening to me. What else can I try doing to fix it? Are there some config files in my package and editor I can delete to revert some settings?

As I mentioned above, it happens on a blank project too.

I’ve built and bundled a completely blank project. When run and switched to full screen, it minimises and cannot be restored. This happens on two different computers. I’ve uploaded it to a new host, let me know if you can’t get it.

http://skull.co.nz/test.zip

Incidentally, I tried to run my original project and the new one above here at work and Chrome told me it was a malicious file and wouldn’t download it. It’s 100% just what Unreal Engine generated - is there something that could be setting off a false positive that we could alert the Chrome devs to?

Unfortunately I was unable to download the file. For some reason my computer still would not allow me the ability to do so. I took a project I have already on my computer and packaged that, then hit alt-enter to fullscreen on a dual screen environment without any failings. has this occurred on a blank project with no additional content?

That is what I was getting as well, I believe it is something that either chrome or dropbox would be in charge of. I will have a look at the file and let you know!

I get the error even when the file didn’t come via dropbox. I’d say it’s just a false positive on UE packaged builds.

You can right-click the download and select “Keep” and it’ll save it for you.

So, any luck? I’ve switched to a single 4k screen and still can’t fullscreen any projects.

Being able to replicate this across multiple configs and computers, it would seem like it’s something we can fix.

Hi AntiDamage,

Unfortunately I cannot open your project to be able to attempt a reproduction. Every time I open it it freezes the editor. I noticed the project is listed as 4.3.1 but maps were made in 4.4.1. Have you since updated this project to the latest build?

That’s strange. I’ll create and upload a new one.

Here’s a new project, created from scratch in 4.4.1. It still demonstrates the same problem.

http://skull.co.nz/test2.zip

Hi Antidamage,

I was able to open the project and could enter fullscreen mode without any problems. I attempted minimizing the screen and pulling it back up without any freezing or hitching as well. However, the project comes in as a black screen and never shows anything else. Is this intended or is there anything that I should be able to see in the project?

You asked for an “otherwise blank project” so a black screen would be correct.

What do we need to do next to debug this?

Try opening your project and then using the ~ key to access the command line. Afterwards, type in r.FullScreenMode and see if that locks your computer up. I just wanted to be certain with the black screen so that I know exactly what I should be seeing, thank you for the confirmation!

Here’s a poor quality video of the same project running on my machine:

These are my GameUserSettings.ini contents on the broken build:

[/Script/Engine.GameUserSettings]
bUseVSync=False
ResolutionSizeX=1600
ResolutionSizeY=900
LastUserConfirmedResolutionSizeX=1600
LastUserConfirmedResolutionSizeY=900
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=False
FullscreenMode=0
LastConfirmedFullscreenMode=2
Version=5

I rebuilt the project so it runs in windowed again and typed r.FullScreenMode into the console - nothing happens.

That is very strange, as I was unable to get it to act anywhere close to what you are showing on either windows 7 or 8. Have you attempted to set up a keybinding for fullscreen mode on your end? For instance, if you set your G key to execute the fullscreen option, do you still get this to occur when in a packaged game?