4.27 Switchboard won't launch


I have a large LED Volume set up on .26 with the nDisplay Launcher. But now in .27 I have run into quite a halting problem.
The Switchboard won’t launch for me at all. Clicking the button opens a empty CMD window for a frame and closes it, nothing happens after that.
In the output log is states that the Switchboard “Launched Succesfully”…

The Switchboard listener seems to work like intended.

I assumed it had something to do with the dependencies of Switchboard, but I reinstalled everything I could think off, and still it won’t launch.
Visual Studio 2017-2019
.NET framework
Unreal Engine itself
Python 2.7 and 3.7

I’m pretty stumped on this problem, and don’t know for sure if what I tried is even related to the problem at all.

1 Like

I have the same problem

1 Like

I am in the same boat also, I loaded up 4.27 for the first time. Just using the nDisplay template. The listener launched fine, then I started the switchboard, UE crashed as it was installing all the stuff that the documentation said it would do for the first time, Now I can’t get anything to go. I’m going to try a fresh install tomorrow. Any advice would be much appreciated.

1 Like

Me too, Have you ever solved it or …?

Check your switchboard.bat file, make sure that the Paths matches, after that, click on the SwitchBoard icon on the UE4 editor, it will launch^o^, hope dev check it again, fix this one on next update, this problem still exists after 4.27.1 hotfix.


Sorry for the late reply. @Arc_lord 's solution seems like it would work.
For me it was fixed after reinstalling everything related to UE4.


I have this issue. The .bat doesn’t have the scripts part in it now it seems. Are u suggesting to add that or was it to remove it?

This is what happens. If I amend the .bat file with /scripts it says .Pythonw not found Dropbox - Switchboard_Issue.mp4 - Simplify your life

Thank you, FIXED

Wooow!! It worked! TY so much!

It worked! Thank you so much!

I had the same problem and THIS FIXED IT! Thank you!

It worked! Awesome! Cheers from ILM.

Have you used UE 5.0.3 and if so have you had the same switchboard issues where it will not launch whatsoever, eems to have persisted from 4.27 into 5.0.3.