(4-27) Loading editor is super slow 4-27 ( and 4.26.2 ) - project specific


When I open my project it takes 15-20 minutes to open up the editor.

On the logs it say :
2022.03.14-05.06.47:119][ 0]MapCheck: Map check complete: 0 Error(s), 0 Warning(s), took 17.469ms to complete.
[2022.03.14-05.06.47:134][ 0]LogFileHelpers: Loading map ‘MainMenu1’ took 937.002
[2022.03.14-05.06.48:419][ 0]LogUnrealEdMisc: Total Editor Startup Time, took 951.274

[2022.03.14-05.06.54:562][ 0]LogLoad: (Engine Initialization) Total time: 957.42 seconds
[2022.03.14-05.06.54:562][ 0]LogLoad: (Engine Initialization) Total Blueprint compile time: 0.00 seconds
[2022.03.14-05.06.55:196][ 0]LogContentStreaming: Texture pool size now 1000 MB
[2022.03.14-05.06.55:723][ 1]LogRenderer: Reallocating scene render targets to support 1360x592 Format 9 NumSamples 1 (Frame:3).
[2022.03.14-05.06.56:206][ 2]LogAssetRegistry: Asset discovery search completed in 950.1291 seconds
[2022.03.14-05.06.56:390][ 2]LogCollectionManager: Fixed up redirectors for 0 collections in 0.000007 seconds (updated 0 objects)

This map is empty ( one empty default character on it ) - with no game mode overrides etc.

So far what I tried :

  • If i create a new project it works, but as soon as I migrate my blueprints it behaves the same.
  • Deleted all " unnecessary " folders and rebuilt them ( appdata cache, derrived data cache in project, binaries, intermediate , saved, plugins. )
  • Converted the project to c++ - right now it is blueprint only since the migration with 0 custom code but previously steam achievements were integrated. ( removed it from config files and all blueprints related to steam )
  • Reinstalled EU4
  • Updated the project to 4.27.2 ( from 4.26.2 )
  • Packaged the project ( to windows ) - no error or warning came back.
  • Windows updates, video card updates, directx etc has been checked - everything is up to date.
  • Tried disable ddc - did not make any difference.
  • Right click - validate assets in folder. Validated just fine.

On packaging it say : LogDerivedDataCache: Warning: C:/Users/Admin/AppData/Local/UnrealEngine/Common/DerivedDataCache is very slow (0.13MB/s) when accessing C:/Users/Admin/AppData/Local/UnrealEngine/Common/DerivedDataCache/2/6/0/TEXTURE_E01F4250BECD420DA9CE63B5EECEC2C2_BGRA8_2BFA297B4DB1977487265E9F2FEE95F__D771B1704880
4F0505F322711016796777D09FEA.udd, consider disabling it.

The project is about 2.48GB ( content folder ) and the packaged project is less than 1.38 gb, so its not a giant project, but I worked on it for about half year and It broke down a month ago - after I have imported spritesheets, however removing them does not solve the problem.

My Pc should not be the problem since other project works just fine - also 32gb ram, ryzen 2600x processor, radeon rx590 video card.

If you have any suggestion please let me know. Much love!

Full log here : Log - JustPaste.it

Are you using a version control system?
Have you tried to roll back changes?

I dont use any version control, so sadly its not an option to roll back for me.

It’s very bad, I strongly recommend using such a system, otherwise, you will break the project at any moment and lose a branch of work.
Can it be connected with hdd/ssd hardware? Is all other stuff loading fast?
Have you tried to fix up redirectors?

If I use an EMPTY map - and do not change anything - it opens just fine, however if I try to open blueprints it freezes for 15 minutes.

I see the only one way, you have to split the project into some pieces and try to import them into a new project piece by piece. Each stage must be saved at any version control

Will try, thanks for the help! :slight_smile: