Download

[4.27] Cannot generate source files

I am trying to switch version from 4.25 to 4.27 for some old project so I can get rid of the old version.

For some C++ projects I could only move to 4.26 as 4.27 showed me following error.

Running .../UE_4.27/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="...MapTests.uproject" -game -rocket -progress -log="....log"
Discovering modules, targets and source code for project...
While compiling ...\UE_4.27\Engine\Intermediate\Build\BuildRules\UE4Rules.dll:
error CS0042: Unexpected error creating debug information file '...\UE_4.27\Engine\Intermediate\Build\BuildRules\UE4Rules.PDB' -- '...\UE_4.27\Engine\Intermediate\Build\BuildRules\UE4Rules.pdb: Access is denied.
ERROR: Unable to compile source files.

I tried making the UE4Editor.exe as well as the UnrealBuildTools.exe to run as Administrator. That didn’t help, also unchecking “ReadOnly” in the folder properties for the whole folder didn’t help.

When changing to 4.26 it works, but I’d still like to move to 4.27 (or maybe later at some point).

Thanks in advance and cheers!

My AnswerHub post sadly still waits for approval by a moderator… What could be off with it, that I cannot post it?
https://answers.unrealengine.com/questions/1047616/427-cannot-generate-source-files.html

which IDE are you using ?
try to run VS as admin as well.
Other than that from what i read from blog/forum microsoft never give support for ue4 with VS and am guessing epic is pulling some features from ue5 to ue4 latest version, so the more you use, it will be less and less stable with VS.

You might consider to use jetbrains rider, it free till nov so you might give it a try. I dont thk you can install ue4 directly with Rider but you can open .uproject directly without generating files with VS. At least you are sure that you are kinda get some stable support with ue4.

I am using VS2019 but I am not sure this is where I should look for the solution…

I cannot even generate the source / solution files from the .uproject file after changing the engine version. So in my opinion it has to be some Engine related issue.

Sorry to bump this… The problem of not being able to generate source files kind of fixed itself. Maybe there was some version update I missed or maybe it was still just some local file permission issue that magically fixed itself.

Nonetheless, I could generate my source files, the builds worked fine, and all the projects could be migrated to 4.27.

Now there still seems to be an issue with project files for 4.27 projects. When trying to open them from the .uproject file, an error message pops up saying “Failed to launch editor”. This isn’t affecting only code or migrated projects but others like the Content Examples as well (at least for me).

It’s not that big of a deal as I can still open all my projects by starting my projects from the launcher / executing the engine first and browsing to the project folder, but as I used the uproject files very frequently, I still wanted to ask if anyone else experiences this or maybe even knows how to solve it.

Thanks and cheers!

EDIT: Unfortunately, because of this, also desktop shortcuts don’t work anymore for me :’(

i would’ve hit “clean all” and “build all”, and then come back the next day. :slight_smile: