4.27 and Steam Audio - doesn't "appear" to work

I’m trying to use Steam Audio 2.0 Beta 17 on UE4.27.1. It doesn’t appear to be working, or maybe it is but I can’t see the “Attenuation Plugin Settings” in the Sound Attenuation details. All other options were available before and attennuation worked with the native UE4 audio processing and attentuation still works now but I don’t believe it’s using Steam.

This is what I’ve done so far:

  1. Added the -audiomixer command in the shortcut
  2. Enabled the Steam Audio plugin
  3. Went to the settings and Changed the “Platform - Windows” Audio settings to use Steam (although this is probably only important at compile).
  4. Created custom Sound Attenuation Settings - no Steam plugin settings seem to be available.

Anyone else tried this? Am I missing a step? Or is it just working and I’m blisfully unaware? Any other ways to check?

1 Like

For me the example project “Spatial Audio Temple” is also not working with Steam Audio. No sound is played. When i change the Attenuation Settings it’s “working” ( I start to hear sound).

Is there maybe a problem with the SA_SteamAudioMusicAttenuation asset?

Hope we figure this out. I want to try it.