4.26 Upgrade TSubclassOf problem

I recently upgraded my project to 4.26 from 4.24 and noticed a couple things off when using class parameters to functions. I have two use cases, but I think they’re related.

The first is the easy one:

UCLASS( Abstract )
class TypeA : public UObject { };

class TypeB : public TypA { };

UFUNCTION( BlueprintCallable, meta = (DeterminesOutputType = "Type") )
TypeA* FindObject( int ID, TSubclassOf< Type A > Type );

Now even though I may not be able to construct an object of TypeA I should be able to ask for a TypeB instance as a TypeA. But now, types marked up as Abstract no longer seem to to show up in the drop down when using functions setup like this in Blueprint. This worked fine in 4.24 but no longer seems to. I’m not sure if it broke with 4.25 or 4.26. I tried the AllowAbstract markup, but that doesn’t seem to work with UPARAM.

My other case is when working with custom K2 nodes. I see the same behavior for pins that I’ve created that use the UEdGraphSchema_K2::PC_Class Pin Category. My only solution there has been to temporarily remove the Abstract markup. I’m not sure what my alternative is. Even if AllowAbstract worked to solve the previous issue, I don’t have a property or param to apply any metadata to.