[4.26] Cannot package for android

Hi everyone,

I am having a hard time packaging for android on UE4.26. I keep getting the same error over and over no matter what I do.
My entire environment is set up to package for android below 4.25 as well as “for and above” 4.25 so I know the problem isn’t some missing environment variable or SDK/NDK installation. I was actually able to package for android up to 4.26 preview 6 but since preview 7 and with the 4.26 official release I cannot package.

This is the error I keep getting:


UATHelper: Packaging (Android (ASTC)): Z:\app\src\main\java\com\epicgames\ue4\GameActivity.java:3217: error: cannot find symbol
UATHelper: Packaging (Android (ASTC)): powerManager.addThermalStatusListener(getMainExecutor(), new PowerManager.OnThermalStatusChangedListener() {

Has anyone seen this?
Many thanks in advance.

2 Likes

I’ve been trying as well, no luck…

Also having the same exact problem.

I asked on the Unreal Slackers ar-vr channel and got this reply:

  • newer version of android NDK has that function
  • 4.26 updated the NDK again to higher than 4.25

Try to update android studio

I installed the 4.26 Preview and had this error. Than i made this tutorial UNREAL ENGINE 4.25.1 PACKAGING FOR ANDROID TUTORIAL UPDATED! - YouTube and it works. Than I update to 4.26 Release and had the Error again. Than I switched between my old Codeworks SDK and the SDKs i installed from the tutorial and now it works again. I dont know why… it tooks me a day… maybe it is problem with the “Accept SDK License”

Hi. I have launched on my android device, and I got this error. (When I package, I have this error). I open Android Studio (3.5.3) and install SDK API lvl 29 (it’s Android Q). Next I try again package my project. And it worked! )


SuccessfulLog.png
UE4SDK.png

6 Likes

Just downloaded android sdk 29 and everything worked fine

4 Likes

Has anybody tried to use GooglePAD (Google Play Asset Delivery) to try and package a game using App Bundles rather then APK’s?

Is there any solutions to this yet? I’ve reinstalled all my android SDK and NDK but still nothing

this is the solution

3 Likes

UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): ====16-03-2021 21:56:02====PREPARING NATIVE CODE================================================================= UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): On build machine. UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Fixing minSdkVersion; NDK level above 19 requires minSdkVersion of 21 (arch=armv7) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Copying permission_library directory to staging before build UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Directory C:\Users\piyubhoir01\Downloads\Compressed\UE_4.19/Engine/Source/ThirdParty/AndroidPermission/permission_library copied to C:\Users\piyubhoir01\Documents\Unreal Projects\TrollBall 4.19\Intermediate/Android/APK/JavaLibs/permission_library UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): ==== Writing new GameActivity.java file to C:\Users\piyubhoir01\Documents\Unreal Projects\TrollBall 4.19\Intermediate/Android/APK\src\com\epicgames\ue4\GameActivity.java ==== UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Copying new .so C:\Users\piyubhoir01\Downloads\Compressed\UE_4.19\Engine\Binaries\Android\UE4Game-armv7-es2.so file to jni folder… UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Preparing native code for debugging… UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): ERROR: System.IO.DirectoryNotFoundException: Could not find a part of the path ‘C:/NVPACK/android-ndk-r18b/sources/cxx-stl/gnu-libstdc++/4.6/libs/armeabi-v7a/libgnustl_shared.so’. UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at UnrealBuildTool.UEDeployAndroid.CopySTL(AndroidToolChain ToolChain, String UE4BuildPath, String UE4Arch, String NDKArch, Boolean bForDistribution) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at UnrealBuildTool.UEDeployAndroid.MakeApk(AndroidToolChain ToolChain, String ProjectName, String ProjectDirectory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean bIncrementalPackage, Boolean bDisallowPack agingDataInApk, Boolean bDisallowExternalFilesDir) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at UnrealBuildTool.UEDeployAndroid.PrepForUATPackageOrDeploy(FileReference ProjectFile, String ProjectName, DirectoryReference ProjectDirectory, String ExecutablePath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bIsDataDeploy) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at AndroidPlatform.Package(ProjectParams Params, DeploymentContext SC, Int32 WorkingCL) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at Project.Package(ProjectParams Params, Int32 WorkingCL) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at BuildCookRun.DoBuildCookRun(ProjectParams Params) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at BuildCookRun.ExecuteBuild() UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at AutomationTool.BuildCommand.Execute() UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, Dictionary2 Commands) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at AutomationTool.Automation.Process(String] Arguments) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at AutomationTool.Program.MainProc(Object Param) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): at AutomationTool.Program.Main() UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): (see C:\Users\piyubhoir01\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Users+piyubhoir01+Downloads+Compressed+UE_4.19\UAT_Log.txt for full exception trace) UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): AutomationTool exiting with ExitCode=1 (Error_Unknown) PackagingResults: Error: System.IO.DirectoryNotFoundException: Could not find a part of the path ‘C:/NVPACK/android-ndk-r18b/sources/cxx-stl/gnu-libstdc++/4.6/libs/armeabi-v7a/libgnustl_shared.so’. UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): BUILD FAILED PackagingResults: Error: Unknown Error

Please Help

what java version do u have?

yas, it is
i download android sdk 29 for android 10 and place it to C:\NVPACK\android-sdk-windows\platforms under name android-29
and justt done, work fine with stupid outdated nvidia codeworks )))))))))))

2 Likes

Thank you. Me too.
BUILD SUCCESSFUL…!
Hurrah!

Yoohoo, thanks!

Thanks! I’ve been trying to find the solution for so long

Working configuration for Unreal Engine 4.27
Only two checkmarks in “SKD Platforms”



And some checkmarks in “SDK Tools” with latest command-line tools


Not sure that Cmake options make sense

1 Like

what is your set up in ue4 settings with these?

Z:\app\src\main\java\com\epicgames\unreal\DownloadShim.java:14: error: cannot find symbol