Download

4.25 Crashes when trying to delete foliage

Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\Build++UE4+Licensee\Sync\Engine\Source\Runtime\Core\Public\Containers/Array.h] [Line: 674] Array index out of bounds: 61419 from an array of size 61338

This is the error message that I get. Unreal crashes when I put foliage into the level and then try to delete them with the brush tool. Is this a bug? I’ve never encountered this in the previous versions.

If you converted the project it may not be a bug but just an issue.
I would suggest trying to make a copy of the level, delete all foliage and start placing it again.

I tried that but it still crashes. I even created a completely new project and still got the same result. Deleting a few thousand foliage with the brush works fine. The crash only happens when I’m trying to delete more than a hundred thousand foliage. For some reason, if I hover the brush over a group of foliage and then delete it without moving the mouse, it won’t crash. But if I swipe the mouse while trying to delete more than one group of foliage, that’s when it crashes.

I did some further testing and I found out that it only crashes when ray tracing is enabled. I tested this on two workstations, both of which have just one landscape, a directional light, and a foliage mesh which I got from the starter content pack.

Have same problem, with raytrace enabled. Every time i try to erase foliage with brush ue4 crashes

I posted this problem on the Unreal Engine Answerhub but I haven’t gotten a response yet.

Have you encountered any problems with the foliage brush size in 4.25?

If you mean increasing and decreasing the brush size, I haven’t encountered any problems with that.

Any update on this? I’m also getting the same issue when trying to remove foliage with the brush, while ray trace is enabled…

Still getting the same problem. Is their a way to contact Epic about this?

There is a quick way aound is to switch view mode to unlit while deleting. It doens’t crashes.