Download

4.25.4 I can consistently get this error message and crash UE

I have a pretty large scene but nothing crazy with materials yet. I was adding reflection capture spheres (10 of them) to one floor and was getting ready to copy them to the floor below but I keep getting this error message which crashes unreal/ Funny thing is i am running a ryzen 3950x system with 32 gigs of ram, a 2080 TI card with 10 gigs ram and both the computer ram and vram is below 50%. This is not good as I am trying to get a project done and setup for lighting and materials.

Any help would be immensely appreciated.

What are the sizes of your textures?

Probably set your reflection capture resolution too high

So I made sure I had my paging allocation set, restarted computer and Unreal Engine, created a test project using the ArchVis Tempalte project with the default building model and sunsky asset in it, created 8 reflection capture spheres in it with a size of 600, selected all of these and then went to Alt Drag them up to copy them and immediately got the message again with a UE crash. I did not touch one setting in the template project.

I am using 4.25.4 I am going to try this in another version.

Artistchampion, thank you for the replay but I only have 3 textures in the project at the moment. A glass shader, a marble shader with a 4K texture and a chrome shader. Everything else is just a diffuse color with no texture.

Hello Akiras and thank you for responding. In the template project I describes where I did not touch any settings, I still had the error. What would you recommend as the setting?

Well, I am getting nervous this is a problem I will not be able to work around as it is something with the engine/ editor. I have been using Unreal since 4.22 and had not run into this issue. I had done an archvis project in 4.22 that had a good many materials with reflections and quite a few reflection sphere captures with no issue whatsoever.

I am able to create this crash in both 4.24.3 and 4.25.4 using just the default archvis template scene. lay out 8 reflection captures overlapping one another on one plane and then select them all and try to alt drag copy them above and there is an instant crash.

Since there is no archvis template project in 4.23, I had to use one of my projects where I created 8 reflection sphere captures the same way, copied them above one another 48 times with no issue. I really need a fix for this as I am trying to do a project that has a deadline.

I am not sure but the issue appears to be related possibly to the Archvis Template in 4.25 and 4.24. I just tried this again in 4.25 using the Collab Project Template in the Architectural Scene. There is a default building in there with alot of glass and reflections. I was able to create and copy 48 reflection spheres in that scene with no issues.

The major difference between these projects that I can see? The Archvis Template comes with the SunSky BluePrint Plugin where you can change the environment light with time of day and such. The concept seems cool but it is a no go with not being able to create multiple reflection sphere captures.

Now what do I do? I have a project where I have setup and brought in alot of assets, started to set up all of the lighting and just got into texturing. I was looking on the forum and it appears I can just migrate the entire project to another project setup without this SunSky. Better yet, is there a setting in this sunsky blue bring that could be changed to fix this or could I cleanly delete the whole stinking system and bring in the standard BP_Sky_Sphere I am familiar with?

Dude… did you try lowering the reflection resolution? It’s set to 2048 in the archviz template, that will create an HDRI that is ~200mb for every reflection capture in the scene.

Set it to something lower… Literally anything will probably work, 1024, 512, 256, etc. Just keep lowering it until you can create an appropriate number of captures.

For reference the “maximum quality” game templates have reflection captures set to 128. I have no idea why it is set so absurdly high in the archviz template, but it’s not the first bad thing that has been put into a template so I am not surprised.

No, I did not and I probably should. I was kind of panicking and just figured Id migrate over to clean project. The guys I am working with on this project don;t care for these tempalte projects anyway when bringing in blueprints such as the VR setup so it may have been for the best anyway.

Still, why not start with something reasonable like you mentioned. Thank you for the help and good information.

I get this error in 4.26.2 whenever i try to build reflection captures for my level… the resolution in settings is 128 (the default.)…

This is getting stupid. I have nvlink 2 rtx 3090 24gb ram each… And its saying im out of video memory… wtf?

I got it to build once properly by migrating the project to a brand new game project… and now it simply wont… it still gets this same error…

I wish we could get in touch with the UE4 devs… they will never look at our bug reports and we will never know if they have so provide them with more information… the currnet bug report system is STUPID AS HELL… and POINTLESS if we cant communicate to add information to the bug. Epic so focused on adding features that they wont actually make their engine work… Answers unreal was decent but hte new bug report system is a backwards step…