Download

4.24 Performance

Hello,

I just updated to 4.24 from 4.22 and noticed a drop in performance. On a very basic level (the default one) FPS drops regularly. For me the FPS drops lower than 100. And this is a default level. No objects.

Here, take a look at the screenshots:
This is 4.22 - UnitGraph does not show any drops

And this is the screenshot I took in 4.24. Note the spikes on the unit graph. FPS also drops during these spikes.

What could be the problem? Is that possible to fix?
Is it time to upgrade my PC? I don’t really want now.
If I can’t fix this - then I would have to keep using 4.22 for development.

p.s. By the way, the screenshots I took in 4K. This is my working resolution.

These spikes are also happening in Fortnite.
So sooner than later Epic have to figure out what it is and fix it because players won’t upgrade PC just to keep playing, not majority at least…

Last time something like this happened, was a problem with NVidia drivers.

Good, they filed a bug!

If you experience the same thing - please open the bug and vote for it - maybe they will increase its priority.

The exact thing happened to me but I fixed it.
All i did was to update to latest nvidia drivers and enable experimental features.
Then there were no spikes.

I’ve seen these fps drops very clearly in 4.24.1 from 4.23,and initially I concluded it might be the effect of landscape tools given current project is mostly terrain,and glad to see,though I pondered it,that the demise of my current PC as noted above,was horribly premature o_0 :wink:

Voted up bug report.

@yateam, what were the actual FPS drop btw,curious if they closely match mine ?

Question:

When was the last actual really STABLE VERSION of the Engine… Anyone???
4.10 was solid. But I’m still on 4.18 atm (just bored of playing the upgrade game).
Nothing of substance has been added for my work, and Chaos still seems fubar!
Anyone know when Epic will do an engine polish with few or no new features???

Around 2016, 4.10 or 4.11 was when I had almost no problems at all besides my own mistakes, everything was very stable.

I think that was before the “let’s do ArchViz stuff!” movement.

I can’t tell now - I am using a different computer (a laptop) where I get barely any FPS at all. LOL.

BTW, seems like they won’t fix the bug. Not sure why. Maybe not enough votes. It is 29 now

Sorry for late reply, but I missed this in my busy world, so just wondering is this still an issue for you and does it impact your decision to stay with epic IF they aren’t addressing such serious issues ? It affects mine unless and untill something is done, if indeed its still a measurable and consistent problem.

Thx

When I updated my drivers everything worked as normal.
But the cause might be not related.

What do you mean “stay with Epic”? :slight_smile:
It is still an issue - I just updated the engine version to 4.24.3 and it still persists

I am curious to see if I have the same issue. A workaround is to Disable UDP Transport… Try that and see if it fixes anything… I am having a suttering every 3 seconds or so and disabling UDP Transport fixes the issue

Hey guys, there is some update to my issue. It has not been resolved in 4.25 Preview, so I started thinking that something is wrong with my computer.

I did not pay a lot of attention to my logs and that was wrong.
I found out that there is some problem with my audio device:


LogAudioMixer: Warning: Audio device removed, falling back to other windows default device.
LogTemp: Resetting audio stream to device id
LogAudioMixer: Display: 0: FrontLeft
LogAudioMixer: Display: 1: FrontRight

Every time a spike happens I get this warning.

I don’t know what the problem is with my speakers. They seem to work fine. I watch videos, listen to music. Even in UE audio works fine. More importantly in UE 4.22 there were no such warnings.
But anyway, now I get these warnings. If I unplug the speakers, the warnings go away, and the performance spikes never happen again.
I tried to update audio drives but nothing seems to help me.

Any ideas?

p.s. BTW, the warning gets logged in AudioMixerPlatformWindows.cpp on the line 315 (method FMixerPlatformXAudio2::OnDeviceRemoved)

I have a friend with some issues with 4.24. We found disabling"Enable Transport" for plugins TCP and UDP, in Project Setting fix the issue.

there has been an in resolved issue with version 4.24.3 for awhile now, and seems to have carried over to 4.25,

was crashing every 5mins in 4.23.3

I switched back to version 4.23.1, haven’t had a “single” crash or issue in 2 weeks, until they fix it, I suggest switching to version 4.23.1

bug fixes “sometimes” are quick, but other times it can take a “long” time to sort them out : they don’t always jump up and down saying here I am.

I am sure they will it, but until they do, I am hanging in version 4.23.1

I suggest u do like wise.

if your an indie dev like I am, you shouldn’t be hindered by it ( in my opinion ) : as indie devs are not gonna be using the cutting edge tech right away.

hope this helps.

God Bless you. May Jesus Christ be Charitable unto you.

John 3 : 16, google it, its cool :slight_smile: