4.24 Open Level is TOO slow now.

I have a project that we are developing since 4.21. It starts in a normal 2D Screen, where you choose options and then the system uses the Blueprint “Open Level” to load the desired level. It was always very fast.

But with the 4.24 version it takes 30 seconds to load next level !!! and during the “Loading” everything is freezed, I cannot check whats going on…

Was there any relevant change to that function ?

Thanks !!..

I just created a new project from scratch without content, and created 2 Levels, the start one is the first, and the second the included Sky illumination one, and a blueprint that loads the other level when clicked… I compiled it and tested it…and is the almost the same… like 26 seconds for loading !!! …so it is not my project…

I was able to replicate this (in my opinion HUGE bug), I created a level in the 4.23 version of the engine, two levels (EMPTY, just prints to test.) each one opening the other after a second. It works perfectly. Then I opened the same project in UE** 4.24**, and it worked well only for three or four times, then it takes about 15 seconds to switch to the other level and works well for two or three times.
Anyone else?

Same here. In the 4.23 level loads almost instantly. In 4.24 it takes ~10-15 seconds.

But no answer from Epic Games yet…

I am changing the project to streaming levels but it is giving me other type of problems because it was not made for that from the beginning…

If you thing you really have a bug, the way to do it is to submit here:

Hi there, it is working for you? Have you tried? In a new project a simple change of scene using OPEN LEVEL and test in 4.24. It would be really interesting to know if it is working for you, I have tried with three different scenes now, one with lots of content, one with very little content (two primitive objects *native from Unreal), and one with zero content *just default scene). None of them worked smoothly, the levels opened but sometimes even after 30 seconds…!

It is a little weird (or maybe not) that too few people use OPEN LEVEL… or only a few people have the issue… that, I would like to know. :slight_smile:

Thank you :slight_smile:

Hi. Have you review the reference viewer? You could be loading a bunch of stuff up front, which could be causing your slow opening… Are there any new plugins that you have in 4.24 that wasn’t in 4.23? Apologies if these questions are not even on the mark, just putting things that I would check. Good luck.


Hi Teak,
Thank you for answering, it has happened in a CLEAN and new installation of the 4.24 version, no additional plugins installed, and tested on EMPTY scenes, you could try and replicate it yourself:

  • Create two scenes, in one put a box and in the other a sphere. (not even imported but native to UE).

  • Open the Level BP in each scene, and after BEGIN PLAY, put an OPEN LEVEL node, and call the other scene.

Play on editor, simulate, package… you name it. In the 4.23 version, you would get a flickering of a sphere and a box, and it would work smoothly until you stop it. In the 4.24 version, it might work for two or three iterations, and the it would take 15 - 30 seconds to load the other level.

It would be very nice if you try and confirm this, or tell us if it works well for you.

Thank you so much for trying to help! :slight_smile:

Thanks teak421 and yes as Haykap said… I also tried in a new clean scene without any extra plugins…and happens the same… I sent a bug report yesterday…

Thank you !

Ack! I should have read closer… Looks like HamuQ has replicated it. Nice finding a bug… I guess… <grins>


Epic Games told me, after I sent them that same simple scene, that they don´t see any problem, they don´t have the big load times… very strange…

We’ve reproduced this bug here in MedRoom.
Our project uses Oculus VR Plugin and after disable the Oculus Splash Auto Enabled property the bug disapears.

Below is the change in DefaultEngine.ini


Below is the option in the IDE


Great !!! Thank you MedRoom_dev !! I changed my project using stream levels, but I will try this later… Thanks !

I had similar issue when upgrading to 4.24.1, huge lag after possessing character (30-40s) I tried the suggestion Gryphon1 made in this post Issue with online subsystem after migrating a project into 4.24 - Blueprint - Epic Developer Community Forums, adding higher network settings to DegaultEngine.ini and now everything works like it should :slight_smile:

Thanks medRoom_dev!

disable the Oculus Splash Auto Enabled

…in Project Settings is absolutely the answer to solve our long load times.

Thank you SpencerIO …I will try it

I was having the same problem again, but Yes… the Oculus Splash Auto Enabled was doing the problem… THANKS !!

I am currently having this issue as well. I tried the above suggestions… but there is still a 15 second delay when using “Open Level” in blueprints, and I package the project and run the .EXE. I am using 4.24.3, and have the Oculus plugin enabled, as per the default. Though I do not see a setting for “Oculus Splash”. Do I need to enable any other Oculus plugins? Oculus “Audio”, “Avatar”, and “Online Subsystems” are disabled. Do I need to enable them to be able to see the “Splash” setting? Can anyone suggest what my problem might be?

Edit: Nevermind. I had to update my Oculus software. Now I have the plugin settings in UE4, disabled the Splash Autoplay. And all is working as it should.