Download

[4.24] I can't get cloth physics to do anything at all. Need someone to tell me what I'm missing.

I am currently trying to get what I believe should be a very simple cloth simulation working. I have a loin cloth on a piece of clothing for an animated character. I have painted cloth onto the loin cloth with a paint value of 10,000 as shown below:

However, when I deactivate cloth paint mode and then preview the run animation, the cloth is not doing anything and is simply following the binding to the bones:

Could someone let me know what I am doing wrong here? Painting the cloth appears to have done absolutely nothing.

There seems to be a bug in 4.24 with the cloth. A workaround is to create the clothing data from selection / then activate cloth paint and paint in values (nothing will happen as you haven’t applied it yet)/ then deactivate cloth paint and then apply clothing data.
The only trouble with this is that when you try and edit it, it only edits the section you initially painted. So a further workaround for this is that when you paint the initial values (i.e. before you have applied the clothing data) you can paint the entire mesh with whatever value / then apply the clothing data / then go back in fill the mesh with a 0 value. Then finally you have a clothing system that functions as it should and is editable!

Is this feature still broken in 4.24? I can’t seem to get the cloth to collide with anything in scene or get it to behave properly with wind physics of any sort.

Thanks! I had the same problem and your workaround worked perfectly!

Edit: to resume:
0. Ensure your physics asset is set up correctly.

  1. Create clothing data from section.
  2. Paint 100 value to all mesh.
  3. Apply Clothing Data.
  4. Paint 0 value to all mesh.
  5. Deactivate cloth paint.
  6. Reactivate cloth paint and put the correct values you want.

Also, I had a problem where some parts of the mesh got bigger for some reason. I fixed it by painting only what I was going to put cloth on point 2.