4.24 GenerateProjectFiles error with Visual Studio 2019

Downloaded the 4.24.0 zip from the release branch on Github. Unzipped into c:\UnrealEngine. Ran Setup.bat to download the dependencies with no issues.

Running GenerateProjectFiles.bat gives the following error.

ERROR: Visual Studio 2019 (14.22.27905) must be installed in order to build this target.

GenerateProjectFiles ERROR: UnrealBuildTool was unable to generate project files.

I previously installed 14.22 c++ build files and updated BuildConfiguration.xml per this post to get 4.23 to compile, so they should be available.

Is there another configuration file I need to update? Any help would be greatly appreciated.

Perhaps you updated to VS2019 16.4.0. ?

The exact VC version no. would be 14.22.27906 AFAIK, if you updated to VS2019 16.4.0.

The VC compiler version is a bit picky with Unreal 4.24 now. If you provide the WindowsPlatform.CompilerVersion explicitely (e.g. in BuildConfiguration.xml), it has to be exact now, or will lead to this error.
You can find out the exact version no. by switching to the corresponding directory and start cl.exe.

cd C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.22.27905\bin\HostX64\x64

> Microsoft (R) C/C++ Optimizing Compiler Version 19.22.27906 for x64 (look at the version no. :wink: )

HTH - Cheers :slight_smile:

Here’s the solution that worked for me with 4.24.1, in case anyone else has the same issue with the latest version of Visual Studio 2019 Community.

In Y*ourEngineInstallFolder/Engine/Saved/UnrealBuildTool/BuildConfiguration.xml *use the following config

<?xml version="1.0" encoding="utf-8" ?>
<Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">

Downloading the 14.22 build tools in VS 2019 Community didn’t work but I tried the “Build Tools” for Visual Studio version 16.2](Visual Studio 2019 build numbers and release dates | Microsoft Docs). In the VS installer under the “Individual Components” tab, search for “14.22” to find the relevant check boxes.

Happy compiling!

Hi im having this problem now. Did you download all 14.22 related things or just MSVC v142 - VS 2019 C++ -x64/x86-Buildtools (v14.22)?

1 Like

I’m joining this unhappy club now with 4.25. Any tips on getting out of it much appreciated!

Looks like my compiler version is 14.22.27906. I’ve got a fair amount 14.22 related tools installed for VS2019 Community edition and have tried adjusting my BuildConfiguration to the version my cl.exe reports

I did have some 14.25 tools installed and have removed them. No change.

I have same problem with 4.24 (binary files) and VS (install 2019 after that 2017) but I can’t find *ourEngineInstallFolder/Engine/Saved/UnrealBuildTool/BuildConfiguration.xml * file. In Engine folder I don’t have Saved folder. should I build it?

In another hand I build my project without any trouble but after some changes, building failed and after reverse changes again build failing. I think problem is on xxx.build.cs file how can I solve it? and how can I find error on my code?

1 Like

Hello dear friends, this error happened to me when installing UE4 4.25 I found out that the 2019 version of visual studio was giving an error, I don’t know why.
uninstalled and installed Visual Studio Community 2017 (version 15.9), did the procedure again and the file “GenerateProjectFiles.bat” worked normally!
follow the links of the installations made:

Visual Studio 2017 (version 15.9)
Visual Studio Older Downloads - 2017, 2015 & Previous Versions

Developer Pack .NET Framework 4.6.2 SDK
Download .NET Framework 4.6.2 Developer Pack Offline Installer

I hope it helps! :slight_smile:

WOW. That has been in the back of my mind to try,. THANK YOU.

PLEASE can you tell me what is the difference between MS Build and ‘Incredibuild’ the ‘Intelli’ one is not really ‘Incredi’ anything but a nightmare,

Can I avoid it altogether? It has been the bane of my existence for years.
I simply want to ‘build project files’ for the Oculus Avatar SDK … thing,… My whole studio come to a stand still because typical MICROSOFT things STOP JUST WORKING,… It has never been a problem even for an Artist like myself, when it just doesn’t work. I’m without recourse!!!

Also, do you knw where to go to install Visual Studio for UNREAL ENGINE? Like the… special game… plugins or whatever it need to be ‘connected’ to unreal? I never used to have any trouble until the 2019 stuff, now I can’t seem to do any of it anymore! :slight_smile: The closest I could find was this: ‘Visual Studio Team Explorer 2017 (version 15.9)’ which only ‘came with’ the ‘Core Editor’ and no,. C++ or Unreal or Gam,e no options at all,. I’m sio lost THis used to be so easyI could get right to developing games, Now I am lost ,.

UPDATE: I uninstalled the: 'Visual Studio Team Explorer 2017 (version 15.9) and when it was done, the Familiar Visual Studio 2017 Installer multi package option came up, I found Unreal using the search box ( hope that means the ‘dependencies’ that will ‘link’ this to Unreal) etc and for the first time I am leaving Incredibuild unchecked! I think I read that it need C++ checked,. ( I hope it’s not C# That’s Unity right?) so I will look for that, and Android too for Oculus Quest stuff…
Now things seem more familiar again! Whew :slight_smile: I thought I would leave this breadcrumb of a clue of what worked for me

Try this .

<?xml version="1.0" encoding="utf-8" ?>

<Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">








<!-- <CompilerVersion>14.27.29016.0</CompilerVersion> -->




To solve this problem you need to install the components shown in the picture.

It worked in my case (4.25)