4.24.1 Datasmith no option to import CAD

I do see and have activated the CAD import through the plug-in menu, but I get no option , nor can I import CAD files.
4.24.1 on a brad new 16" MBP
Please help

I have the same issue. I can’t import CAD files now. There is no dropdown arrow next to the Datasmith importer


What happens if you click on the button?

It opens the import window. You can see available file format options below


Hi Kubapie !

Make sure to enable the Datasmith CAD plugin to have all the CAD formats available and restart the editor. :slight_smile:

Hi ,

I have all Datasmith Plugins enabled. I have even tried different combinations of enabled plugins but no luck so far. It also doesn’t work when I create an emtpy archviz project. Update to 4.24.2 Also didn’t help

When you start the editor and check the Output Log, is there the following mention ?

LogPluginManager: Mounting plugin DatasmithC4DImporter
**LogPluginManager: Mounting plugin DatasmithCADImporter**
LogPluginManager: Mounting plugin DatasmithContent
LogPluginManager: Mounting plugin DatasmithFBXImporter
LogPluginManager: Mounting plugin DatasmithGLTFImporter
LogPluginManager: Mounting plugin DatasmithIFCImporter
LogPluginManager: Mounting plugin DatasmithImporter

Yes I have all of them

Are you using a launcher build of the editor or compiling it yourself from the GitHub source ?
If you are using a source build, we do not ship the CAD components for licencing reasons.

Same here even with 4.24.2. There’s the option to import fbx and datasmith files but no actual CAD files on the Mac like .STEP etc.
On the contrary when I bootcamp into Windows there’s a lot more options and all the CAD formats are supported there.
When will you guys support CAD files for the MAC?

I must have missed the Mac part of the thread, we only support the Windows platform for CAD data.

I have the same problem on Windows. Using 4.25 preview 1

Have enabled cad import.

Same here, dissapeared in 4.25 preview 1.

Hey mrboni and Czaja91 !

4.25 Preview 1 doesn’t have the CAD importers, we expect to have it back in preview 2 or 3.

Sorry for the inconvenience !

Windows 4.25 Preview 2 still doesn’t have CAD import option.

Hope the datasmith works again. I was super hyped that 4.25 will gonna fix rhino compatibility but seems like I can’t even import it for now.

Uh, too bad that Preview 2 doesn’t have it. I am also all about Rhino improvements. Maybe Preview 3 will show up as fast as 2.

Previews are weekly releases, the CAD importers didn’t make the cut this week but should back next week for preview 3. :slight_smile:

It is here! Thanks all.

i have the same issue on Windows 4.26.0

do you found a workaround ?

thanks for your help

How about 4.27.1?
The DatasmithCADImporter plugin gets mounted, according to the log, but no support for STEP anywhere.

LogPluginManager: Mounting plugin DatasmithCADImporter
LogPluginManager: Mounting plugin DatasmithContent
LogPluginManager: Mounting plugin DatasmithImporter

When I click the datasmith icon, the log says:

CADInterfaces: Warning: Failed to load CADInterfaces module. Plug-in may not be functional.
CADInterfaces: Warning: Failed to load CADInterfaces module. Plug-in may not be functional.
LogDatasmithXMLPLMTranslator: Warning: CAD Interface module is unavailable. Most of CAD formats (except to Rhino and Alias formats) cannot be imported.

And there’s very few formats available.

This version of Unreal (4.27.1) is built from source.