4.24.0 Unreal Editor not saving any changes

Okay I need some help from, anyone reading this.

I’ve updated to the new version of 4.24.0 today, uploaded a project with Visual Studio 2019. Within the editor I tried to save a actor cube, went to save and it’s not saving the changes that were made.I moved the actor a few 100cm in world space, went to save and I’m seeing these messages coming back from the editor. I close the editor make changes to my source code, recompile and try and save again, same thing arises! Is this a bug that the Engineers missed and if so when will there be a time frame for a patch for this to save changes made. PS: I’m waiting for Google Drive to upload the project so I can submit a “Report a Bug” Log to Epic Games. I was wondering if anyone else is having this issue shortly after the release of the updated version? When I try to exit the editor I have to force close the project thus loosing any changes that I made previously. Never needed to do that before.


Check your task manager and make sure you don’t have another (crashed) instance of editor running same project.

[USER=“434”]BrUnO XaVIeR[/USER] that was the first thing I checked. I closed everything down rebooted the laptop and tried saving in the editor, and would you believe it, it still wouldn’t save. I’ve submitted a Report a Bug to Epic with all the folders and attachments so hopefully they can figure out what’s wrong with this version. Tomorrow (as it’s late here in the UK) I’m going to try again with a clean build for both 4.23 and 4.24 so I can compare like for like, just to make sure it is supposed to be saving. Thanks for the assist. I’ll use your words wisely when re-testing it tomorrow. Best regards Brandon

That’s weird because I’ve been working on 4.24 projects for several weeks already and it is super smooth here, no crashes nor very ugly things happening…

Hi [USER=“434”]BrUnO XaVIeR[/USER] I think I’ve found the issue, but want to give you a heads up, but before I do can I send you a thanks for assisting in the response. When I woke up this morning, I loaded the editor and the IDE to see if I could save the changes and hey presto, it saved. Thinking back to yesterday’s brief comments I had git bash open and I think that was the reason why it wasn’t saving the changes nor in the IDE why it wasn’t clearing the buffer before compilation. So I tried a few things and I can now confirm to yourself and @unrealengine staff that 4.24 is working fine and Case # 00144818 can now officially be closed. Memo to self though work first THEN commit! Best regards and thanks once again for your assistance yesterday. Brandon