4.22 Beam emitter is no longer ticking when paused

Beam emitter is no longer ticking when paused using SetTickableWhenPaused following a SetGamePaused. This problem has suddenly appeared moving from 4.21.2 to 4.22.0 ( this was also fine in 4.20.3) . This is very specific to particle effects with a beam emitter, other particle effect still get ticked when paused. Have noticed that if any beam emitter is now added to a particle effect a red warning message’NO ASYNC TICK’ appears in Cascade’s viewport ( again specific to 4.22) , possibly related?.Can’t find any documents on this or any obvious way to resolve it.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



Unfortunately, it seems that beam particle modules don’t support async ticking at all. Looking at ParticleModuleBeamBase.h CanTickInAnyThread() that just returns false:

UCLASS(editinlinenew, hidecategories=Object, abstract, meta=(DisplayName = "Beam"))
class UParticleModuleBeamBase : public UParticleModule

    //Begin UParticleModule Interface
    virtual EModuleType    GetModuleType() const override {    return EPMT_Beam;    }

    virtual bool CanTickInAnyThread() override
        return false;
    //End UParticleModule Interface

I also have particles that are no longer ticking when paused, even though I set SetTickableWhenPaused to true after spawning them.
I am told that the particle is not using beam emitter.
It started happening after updating to 4.22 as well.

In case anyone still needs to solve this, the solution is to disable “Allow Managed Ticking” on the particle system asset

Credit from this post: Play particle during pause? - #7 by Online_Learner_N2bcT