4.21 Jacketing

Anyone try this out yet? I just tried to use it on a moderately sized scene (multi use building sized, 2000 meshes) with default settings and it locked up my whole pc for maybe 30 seconds, then I assume my video card crashed (gtx 970) and wouldn’t recover. From what I could tell, the jacketing operating finished a few minutes later, but my video card didn’t recover like it usually does.

I was able to blindly shutdown and restart, but still didn’t get any output on the monitors which was pretty odd. Finally got it up again after taking out the card and checking it, finding nothing then trying again.

Not saying the hardware issue was related, just odd. Curious to know what voxel sizes are appropriate for a level of that size before trying again. For reference, I have a level with a building modeled with all of the structural framing. Most of the framing is inside the walls and cant be seen obviously, so I’m looking to group them all up, move them to a new level or just delete them from the level. Source file has everything named solid 1-2000…so I figured this would be a good use for it.

tl;dr : conservative jacketing settings for medium sized level?

Hello, could you check the logs of your project to see if the application crashed? If so could you send the logs to us?

The key factor is not just the number of elements in your scene but the volume taken by the elements you would like to process as well as the distance between the elements you would like to remove and the boundary of your volume. In your case you speak of structural framing that I assume are contained in walls and thus only a few centimeters/millimeters away from the boundary of your volume (wall exterior). You ll have to keep a small voxel size so that the algorithm can detect that there are voxels with “wall matter” between the boundary and voxels with “structural matter”.
So a big number of meshes with a small voxel size will take time: could you work per areas?

You could also try a small subset of walls to see what are the values for your use case.

Just in case, the documentation here is quite complete:…owTo/Jacketing

Hey, thanks for the info Flavien. I did read that page of the docs before trying, but not closely enough. Thinking back, pretty sure I had the skysphere selected when I ran the jacketing command and not the meshes themselves…whoops

I found the log error, and sure enough, out of memory.

[2018.11.10-23.11.30:615][965]LogEditorViewport: Clicking on Actor (context menu): BP_Sky_Sphere_C (BP_Sky_Sphere)
[2018.11.10-23.11.30:654][965]LogSlate: FSceneViewport::OnFocusLost() reason 2
[2018.11.10-23.11.32:087][114]LogSlate: FSceneViewport::OnFocusLost() reason 2
[2018.11.10-23.11.39:897][114]LogSlate: Window ‘Remove occluded meshes’ being destroyed
[2018.11.10-23.11.39:916][114]LogSlate: FSceneViewport::OnFocusLost() reason 2
[2018.11.10-23.11.39:927][114]LogMeshProcessingLibrary: AssemblyJacketing: Processing 1 components, 3968 triangles
[2018.11.10-23.15.14:861][114]LogMemory: Warning: Freeing 33554432 bytes from backup pool to handle out of memory.
[2018.11.10-23.15.14:895][114]LogMemory: Warning: MemoryStats:
AvailablePhysical 781697024
AvailableVirtual 140669550886912
UsedPhysical 767299584
PeakUsedPhysical 11485024256
UsedVirtual 61589827584
PeakUsedVirtual 61594025984
[2018.11.10-23.15.14:897][114]Allocator Stats for TBB: (not implemented)
[2018.11.10-23.16.15:187][114]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2018.11.10-23.16.15:196][114]LogWindows: Error: === Critical error: ===
[2018.11.10-23.16.15:197][114]LogWindows: Error:
[2018.11.10-23.16.15:198][114]LogWindows: Error: Fatal error: [File:D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 200]
[2018.11.10-23.16.15:199][114]LogWindows: Error: Ran out of memory allocating 2048 bytes with alignment 0
[2018.11.10-23.16.15:199][114]LogWindows: Error:
[2018.11.10-23.16.15:199][114]LogWindows: Error:
[2018.11.10-23.16.15:199][114]LogWindows: Error:
[2018.11.10-23.16.15:266][114]LogExit: Executing StaticShutdownAfterError

If you wanna see the full log let me know where to send it, but fairly sure the above is the only relevant part. Thanks for the help, glad to know what caused it.