4.21.1 Admob Support

I’ve done everything in the book to set the ads up, but they still will not work. I’ve attempted to follow every tutorial google could summon. Can someone please assist me? I haven’t had luck on the Answer hub so I was hoping to get something from the forums.

I have exactly the same problem. I tested a free plugin and the ads started working perfectly.
However, i would never publish a game with it (criminals exist).

I have tried moving my project back to 4.19.2, (because i heard the ads were working in that version) but had trouble with migrating content from the newer to older engine version. Duplicating everything manually would be days of work, so that would be the last resort.

I also can’t figure out why the engine doesn’t give users the option to set any admob app id property (because apparently that is required).

Admob app id help says:*

Right now i am analyzing the files like AndroidAdvertising_APL.xml and more, seeing what i can do.
I will respond if i found a possible fix.

Bump. If someone is interested in helping me, I can provide proper details to further elaborate my situation!

@Debaucher G’day - please wait 4-7 days before bumping.

As it turns out, somewhat had replied, but it hadn’t been approved :stuck_out_tongue:

I agree with you, I don’t want to use plugins either! I may try to just create a project and test it on 4.19.2 to see if the ads work in it. Regarding the admob app id, check out the image I attached. The third entry regards the admob app id. I’ve tried it with APPLICATION="" and APP="", I’m not sure which one is more appropriate. If I figure anything out I will update you as well.

My apologies. Thank you for approving that users post!

Try this: https://forums.unrealengine.com/comm…ith-Blueprint=

Mine never worked until i implemented the 7 APIS this tut mentions after you scroll down a bit. Note I think the Google Cloud User Accounts one is no longer needed, and does not show up anyway. Hope this helps.

p.s. the rest of the stuff on that tut may not apply to you directly… but good to look it all thru.

Jerry

I’ve been through that thread numerous times and have done everything they described.

When ever I go to package, I notice that the gradle is being rebuilt and if I put any custom information in my build.gradle (app & main level) they are erased during the packaging process. Any suggestions with avoiding grabbing a new JVM?

Hello, it’s me again.
I said in a previous reply that I would respond if i found a possible fix, but I found myself investing too much time in fixing ads, instead of app quality, marketing, Store listing, etc.
I bought a trusted plugin, and my mobile game is live on the Play Store, rolling all the ads like a charm!

(In the current situation I found myself, this was probably the best decision.)

I am truly sorry for not managing to find a working solution.

I wish anyone all the luck they need for developing great games.