Download

4.19 something wrong with cloth

i just installed 4.19 & my players hair cloth is all blurry. anyone else having this problem? or is it just me??

If it’s blurry then that has nothing to do with simulation, that sounds more like you need to wait a moment for the textures to load fully.

well its only the cloth that is blurry. its weird never seen it before like in 4.18

That’s probably still the texture is streaming in

any way to fix this?

i have the same problem with my characters cape. It has nothing todo with textures, the whole object (mesh) gets blurred by the motion blur at full strength/velocity all the time when there is just minimal movement on the object. Vertecies with 100 skinned wheight do not get blurred, but if they have anything less they get blurred.- i could not find any fix for this, even reimporting and setting everything up from scratch did not fix it.

my test is in verstion 4.19.2

If its related to texture streaming, you can try increasing pool size from the console with something like:
r.Streaming.PoolSize 5000

it is not related to texture streaming.

I have found a work around. Add a PostProcess component to your character BP. Search/Filter for blur. Enable Motion blur and set the Amount and Max to 0. That worked for me. This happens on the paragon character’s cloth. I saw this mentioned in one of the paragon character setup video but the person did not know which exact component to add. He said that the cause had something to do with screenspace motion blur.

I tried this (but in C++) by attaching PostProcess to the character and camera, and it did not work sadly. This really does look terrible and I would like a way to fix it.

You can even witness this issue in one of the recent live streams where they were setting up an animation blueprint with one of the paragon characters. The hair was doing this non-stop.

Bump.
Still looking for a fix.

I decided to sit down and read the docs a bit.

If you want to fix this issue for now, here is a quick solution (for those of you in c++):



camera->PostProcessBlendWeight = 1.0f;
camera->PostProcessSettings.bOverride_MotionBlurAmount = true;
camera->PostProcessSettings.bOverride_MotionBlurMax = true;
camera->PostProcessSettings.MotionBlurMax = 0.0f;
camera->PostProcessSettings.MotionBlurAmount = 0.0f;


Remember to set the cameras BlendWeight to 1.0f, otherwise the motion blur settings will not work.

I’m having the same issue. Did you find a solution? And disabling motion blur altogether is not a solution btw.

One workaround I’ve found is setting Motion Blur Max to 0.75 but it makes strong movements with the camera choppy.

Looks like it’s an unresolved rendering issue

Bump, need a fix. The proposed solution to set motion blur amount and max to 0 doesn’t work.

Hi Everybody

We’re developing a triple A Title at Sabre Interactive and the Publisher is quiet frustrating when we said that with Unreal Engine at this day, or you have motion blur or you have cloth simulation but not both at the same time. When those 2 effects together are the most used in High end actual titles. It basically change the experience.

Programmers insert the mul( mul(float4(Intermediates.SimulatedPosition,1), Primitive.WorldToLocal), PreviousLocalToWorld ) instances but this generate other issues. So the unique solution at this time is to disable at all the motion Blur. the moves of the characters defiantly don’t look the same without motion blur. Especially on ps4, at 30fps motion blur help.