Download

4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly

Talking about drivers, I ended up rolling back to a driver from last year (385.69) because one of the more recent drivers was causing roughly a 30 to 50% drop in fps across the board for me. It’s almost as if Nvidia is intentionally trying to slow older gpus down more, to the point of frustrating you into buying a new one. Sort of like what Apple was doing with their phones…

Not only this, I have rolled back my driver version aswel because since December the new drivers are messing with Vulkan registry values and any application made for Vulkan is failing to find the Vulkan runtime. Several articles have being made telling about this and NVidia is just ignoring to provide a proper fix!

Have you tried manually adding keys? I know that I’ve had to do some regediting for nvidia optimus because some games will load with integrated card, no matter how hard you try to force it to load with the dedicated GPU. RequireSignedAppInit keys had to be added to allow them to run properly.

I wonder if there is a fix like that for the Vulcan issues (I have never messed with Vulcan, so I don’t know if it’s possible or not).

The problem is that doing manual stuff in a development environment put at risk you deploying something which might encounter an user’s machine without it. It should not be the application/game the responsible for fixing this, but I will try to dig if there is a proper way to fix the registry key to point to the correctly path (some more complaints at NVidia’s forum too I guess).

Cross-positing from my thread. Exactly the same symptoms. Completely unrelated to mesh particles or particles. 1060.
Issue is a regression. Tested it in 4.15, works flawlessly.

I agree that it points to that, we realized the issue was not related to particles, because an empty level seems ok, unless we use stat command the issue starts to appear badly over time. A question thou: how can the issue disappear when rolling back driver version? I did as suggested at previous posts and the issue disappeared, at least looks like its gone. If its a memory leak related issue (it shouldn’t have garbage collection at this point, since we talking about rendering thread) it must be at the render module or at the driver.

Did you open a bug report on this? We should add your findings with the #issue number we got.

Hey everyone,
I’ll call some attention to this but, but please make sure you’ve submitted bugs through the bug submission form.

Thanks!

Yes, I’ve sent a ticket.
I can’t say anything conclusive about the driver. I did not experience the issue anywhere else, including previous UE4 versions. I’m on 390.65
I’ve checked other 4.19 projects, I have access to. There is always something that triggers the stuttering, including stat command.
But with draws to render target blueprint it escalates exceptionally quickly.

This appears to be a critical, engine-wide regression in 4.19, affecting all projects on certain machines, including packaged products, not just specific parts of it.

Is filed incorrectly. It is not related to particles directly.

The hitching will be present in all projects, but certain features will make it onset and deteriorate much faster.

So might as well receive a bit more than some attention.

Reproduction steps:

    1. Download test project as provided.
    1. Open with engine version 4.18.1
    1. Open the Content/BugMap.umap
    1. Play in standalone
    1. Enable stat unitgraph
    1. Measure
    1. Wait 15 minutes
    1. Measure
    1. Open test project with engine version 4.19.0
    1. Open the Content/BugMap.umap
    1. Play in standalone
    1. Enable stat unitgraph
    1. Measure
    1. Wait 15 minutes
    1. Measure
    1. Behold!

Test Project drive download.

Stat unitgraph 4.18, after 15 minutes:
StatUnitGraph418.jpg:

Stat unitgraph 4.19 after 15 minutes:
StatUnitGraph419.jpg

**RhiCmd 4.18
StatRHIcmd418.jpg

RhiCmd 4.19
StatRHIcmd419.jpg**

@Kalvothe Might want to point, whoever will be looking at it, here:
**What is wrong with CeateTileVerticesBuffersLegacyInit ? Why would it be called for drawing to render target anyway ? Not cool. **

This one of the main reasons 4.19 is a show stop for me, followed by issues with Vulkan, reflections, all reported, can’t use it as it is. Definitely will wait for 4.20 and don’t bother with all the trouble this version brought to the table, I can’t really expend all of my time figuring out why something stopped working or not working as intended, instead of carying of my own project issues which for now are still based in 4.17 (I know games launching are based on very early versions - like Sea of Thieves is 4.10, but c’mon…)

Would have been useful, if this particular bug was filtered out in testing stage, or at least a notification about its existence posted somewhere. It is a critical showstopper indeed, rendering 4.19 and onwards useless.

I don’t have a clue though, why there are only a dozen of posts about it here. Not everyone is running editor/game long enough to notice ?

Personally I haven’t made the jump to 4.19 yet since I’ve seen nothing but horror stories - and I’ve been unable to make an installed build since launch. Quite a lot of the rendering plumbing was changed for Temporal Upsampling I believe - it’s quite possible all that rummaging around has caused some problems.

Maybe Devs are skipping odd-numbered releases… That’s what I normally do, as its too much work otherwise (as Nilson alludes too)… 4.18 has been pretty stable too (for me anyway). Not saying its 4.10 all over again, but definitely seeing less random out-of-video-memory crashes, which is a relief. :slight_smile:

Might be a coincidence yeah, but 4.18, 4.16 were remarkably stable for me. :slight_smile:

I would not even know about the issue, if not random chatter on discord, because frankly saying I did not bother giving 4.19 a proper test for I was not intending to use it, other than for several my personal pet projects.

¯_(ツ)_/¯

I am frankly in doubt, what additional information could I provide.

Would mean magnetic declination for place and time, when the issue occurred, be helpful ?

I know my telescope needs such calibration information, could Unreal Engine actually benefit from it as well? :eek: Possibly larger MMORPG maps?
Sorry for the silly comments, but that was a pretty funny science comeback. :stuck_out_tongue: I assume that was a bug report response?

Was this a response for the issue we are discussing? More conditions would be the use of NVidia card maybe? Seems a common denominator, as for processor it was reported several models.

Yeah but… I don’ think I should put: take out whatever card you have installed and stick in MSI 1060 3gb as a reproduction step. dxdiag file should be enough.

The response for follow-up report with test project and hand-holding step by step guide to observing the issue reads as follows:

What was updated? How was it updated? What links were added? What steps?
No clue.

It is not an issue with particles.
It is not an issue, restricted to specific project.
It is not an issue, restricted to editor only.
It is not an issue specific to nvidia gpus.

Anyhow, the web is full of recent deteriorating stuttering complaints in some UE4 games, including fortnite.
One gentleman mentioned stuttering on IOS render thread in 4.19.

It has nothing hardware specific at all. Absolutely nothing.
Even if it is hardware specific, then it is not hardware specific at all.
Hardware specific issues do not appear after a change in software out of thin air.
If they, do, than it is definitely not to be blamed on hardware.

https://forums.unrealengine.com/development-discussion/ios-development/1460113-rendering-performance-problems-in-4-19
Our butter smooth 30fps experience is gone after updating to 4.19. After testing countless of ini settings and tricks it seems that nothing helps.

I’ve been watching this problem since the first page of this thread since its been affecting me since 4.19.0. Initially it was tracked down to particles, but I always knew there was more to this story. I haven’t worked with any projects that contain any of the causes listed here so far, yet I still experience the stutter. I’ve recently started working with UE4 on my laptop (surface book) in the last few weeks. The book can barely run UE4 as it is, yet surprisingly, no stutter. When I work on my desktop, it starts stuttering within 5 min until it cripples the engine.

For reference, both run Nvidia cards, and both have been working on the same project recently. Obviously there are severe stat differences in the machines, yet the more powerful one is suffering and the laptop isn’t.

Agreeing with Deathrey that this can’t be just a hardware issue. I’ve had the same hardware since I started with 4.13. 4.19 is the only engine version that produces this problem. I’d love to help solve this, but I really have no idea how to track down the cause.