[4.19.2] Using Make MovieSceneSequencePlaybackSettings node with Create Level Sequence Player node starts the sequencer at random times whatever the settings

Just like the title says.

This has been brought up before and seems like someone marked it as a duplicate for some reason, couldn’t find the duplicate and it certainly not fixed:

If you pause the game during the sequence and take a look at the generated LevelSequenceActor and in particular Random Start Time setting it’s always checked whatever the settings you’ve made in the blueprint. Below is a blueprint that generates this bug and circled is the discrepancy between the settings and the actual result.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.




I already made a bug report in the link you described 3 hours ago. I didn’t know if I should’ve posted that on here since I haven’t got a ticket or a number for the bug.


I’m kinda sad to see, that my bug report wasn’t reacted to in any way.
How do people work around this bug, since it screws up the cinematics?

This should be fixed in 4.20. Can you try that out?

It’s related to this issue: https://issues.unrealengine.com/issue/UE-47615

Okay nice! Now it seems to be fixed!
Thank you very much!

Sorry for the long time until reply. I’m a hobbyist and didn’t come back to this until today.