4.19.2 UBT Error Failed to produce item

I’m wondering if anyone can help with a problem that is occurring when I build from UE4 4.19.2

I am currently getting an ERROR: UBT ERROR: Failed to produce item: D:“ProjectFolder”“ProjectName”\Binaries\Win32"ProjectName"-Win32-Shipping.exe. I should note that I also experience this error when building as development.

It looks like it has something to with the the UnrealBuildTool.exe as I’m also getting “Command failed (Result:5)” but I cannot be sure. I have found other people have had the same problem but I have tried the following with no success;

  • Tried to build on another computer (with same error occuring)
  • Installed Unreal Engine Installer in Visual Studio Community 2017 (15.9.8)
  • Installed Windows 8.1 SDK
  • Deleted binaries/saved/intermediate folders

I have had a successful build when building a new blank project while this problem as been happening but for some reason I just cannot work out why the build keeps failing.

I will also include a log.txt file. link text

I hope someone can help.

Thanks to everyone who may have seen this error but I have found a way around the problem.

  • I create a new blank Unreal project with the same project name as the problem project but I saved it in a different location.
  • I then copied the ‘Content’ folder from the original project to the new project
  • I exported some ‘Project Settings’ from the original project such as “Inputs” and imported the .ini files into the new ‘Project Settings’.

Once I did all that, UE4 managed to build successfully. I’m not sure if something had become corrupted and it wasn’t a route I wanted to use but I can’t complain about successful results.

Thank you, everyone. Hopefully this helps other people who have found themselves with the same trouble.