Download

4.18 Control volume of Media Sound component?

I have a video setup using the new media framework from 4.18, including a Media Sound component in an actor BP. Everything is working as expected. However, I cannot figure out how to control the volume of the Media Sound.

Is there any documentation on how to control a Media Sound’s volume?

Hey Ken! Does the attenuate work or does it play the sound all over the level? NOTE: The attenuation will work if the video is in the center of the map, if you move the video from the center then the attenuated sound will still be playing from the middle.

Hi Ken_Brueck, did you try using Set Volume Multiplier?

Media Sound Component just wraps the Synth Component, so it should have access to all the basic Synth Component BP API functions.

This is strange — I don’t even have an option for Set Volume Multiplier.

For what it’s worth, when I uncheck ‘Context Sensitive’ and browse Synth > Components > Audio, I don’t see a Set Volume Multiplier there, either.

Hmmm, weird. Try activating the Synthesis plugin. Maybe the API lives there?

Thanks Dan, unfortunately it’s already enabled in my project. Here’s a screenshot of all my activated audio plugins.

Weird! Are you on the latest version?

I’m on 4.18.2 and even verified my install yesterday as a sanity check. Your reaction tells me something is really wrong… haha.

Well this is unfortunate. I still don’t have a volume multiplier API after I:

  • Uninstalled/reinstalled 4.18.2
  • Created a new project
  • Enabled the synthesis plugin
  • Created a new blueprint and added a Media Sound component

To be overly verbose about my steps in case I’m doing something wrong, after opening the new BP I clicked the green “+ Add Component” button, typed “Media Sound” and selected that item. I then dragged that component into the event graph and dragged off its pin. When I type in ‘volume’ I see nothing related to audio (I do see some physics volume options).

Any ideas what else I could try?

Hmmmm. Try turning on the New Audio Engine. It’s in Early Access right now. You can open the Editor with command line -audiomixer or any of the other methods described in the sticky thread.

I think I have it enabled. Is there a way to know for sure if it’s turned on?

Hi Ken_brueck,

You can check your output log by searching for the term “audiomixer” and you should see logs indicating the AudioMixer module has been used.

If you do not have the new Audio Engine enabled, then nothing will show up in the search.

Thanks again Dan. It looks like audiomixer is enabled unless you see anything wrong with this:

LogAudioMixer: Display: Sample Rate: 48000
LogAudioMixer: Display: Callback Buffer Frame Size Requested: 1024
LogAudioMixer: Display: Callback Buffer Frame Size To Use: 1024
LogAudioMixer: Display: Number of buffers to queue: 1
LogAudioMixer: Display: Max Channels (voices): 0
LogAudioMixer: Display: Number of Async Source Workers: 4
LogAudioMixer: Display: Initializing audio mixer.

I am having the same issue. Trying to set the playback volume of a Media Sound component but nothing mentioned seems to work. Anything else to try?

1 Like

I was never able to get a SetVolume command to appear, even on entirely different machines with entirely different 4.18 projects. If Dan hadn’t been trying so hard to help in this thread I’d be convinced it just wasn’t possible.

In the end, I stumbled through an awkward workaround using a SoundMix, a SoundClass, and a SoundMixClassOverride. SetSoundMixClassOverride has a volume input. I’m convinced it’s all wrong, but I can at least change the volume of video now!

Thanks @ken_brueck . I also ended up creating a custom sound class and setting the volume there. I couldn’t make it work in any other way.

I have the exact same problem in 4.19.2. When compiling for Oculus Go I am unable to influence the sound of the movies. On Rift no problem at all. But on Android it just does not work. To me it seems there must be something going on with the Media Framework for Android.
@dan.reynolds could you check if this is a known issue for the Media Framework? Thanks. I know I have it since 4.14.

My work around now is to separate video and audio tracks and import them as separate assets.

I’m also still experiencing this in 4.18.2. Definitely seems like an issue, since the only “volume” contextual options for a Media Sound component appear to be physics related.

In case this helps anyone; it appears the Media Sound Component creates a child Audio Component to actually play the sound, so a quick workaround is to use a for loop to scan for and store that Audio Component and then adjust the volume on that component.

Despite this, I have still been unable to get any of these working for GoogleVR on Android in 4.18, despite it working just fine in the editor, VR-PIE and VR Standalone. @MillhouseOne I suspect an issue with the Media/Audio Framework integrations with Android as well like @martin_vr mentioned. Any info about this? Unfortunately, I have no idea how this fares in newer engine versions since I cannot do GoogleVR in a version later than 4.18 without running into SDK issues.

I had this same problem, and then I realized that somethin a lil funky is goin on:

If I scroll through the Details panel of my media sound component, there’s no Set Volume Multiplier option. If I search for it in that Details panel, still nothin. However, if I drag the media sound component onto my event blueprint, and then create a context-sensitive node by dragging out from the ■■■ on the media sound component, I’m given the option to set volume multiplier if I search for that. Perhaps y’all are dealing with a more complicated issue, but that’s what fixed it for me!