4.18 can't launch on the device when gradle is enabled instead of Ant!?

i can’t launch on the mobile using gradle instead of Ant here is apic of the log

i can launch it if i disabled gradle

i have accept the sdk license

just one question is it necessary to fill this configSdk page in 4.18 in order to launch it?

sorry for my bad english.

Same problem here. Ant works fine, gradle dont :frowning:

Try after Update Android SDK by using “NVPACK\android-sdk-windows\tools\android.bat”

Same here. I can make working build in 4.17

got the same problem, open the license file in android sdk with notepad, it should have only a key like this 8933bad161af4178b1185d1a37fbf41ea5269c55, but when you accept the sdk license it puts a white line before and have error.

just remove the white line , hope this helps

i’v tried this but still dosn’t work.

dixfn7m has an answer that worked for me:

I tried that but it only worked while using ANT. When switching back to Gradle it stopped working.

dixfn7m has an answer that worked for me:

it finally worked!!! thank.

@SUMA01, it worked, thank you!