Download

4.17 keeps launching Oculus home every time I hit play

Hi,

Ever since I started using 4.17, I noticed that Oculus Home launches every single time I hit play (Alt+P). This in turn keeps my Oculus Headset active and warm even when I don’t want to use it at all, and that pisses me off. If I close it, it starts right up as soon as I hit Alt+P again. In 4.16, Oculus home would launch only once on editor launch, and if I closed it, it would not bother me again, but in 4.17, it keeps popping up all the time. That’s quite a terrible regression. Any idea how to fix it would be much appreciated.

Thanks in advance.

Just disable Oculus plugin in Project Settings -> Plugins.

Thank you so much :slight_smile: I did not expect it to be that easy :slight_smile:

Hi, i disabled it in the Plugins, and it still keeps starting my oclulus home :frowning:

This is still an issue with 4.21. Even after you disable Oculus plugin it still starts the Oculus aplication. Does anyone have a fix for this?

EDIT: Found the issue. The plugin has to be disabled from the plugins menu as shown in the picture attached and not only from the project settings.

This is still a pretty bad workaround. It disables VR Preview completely even when you occasionally want it. Say I’m doing layout all day, I’m not going to be sweating inside my Rift for 8 hours, and having the Home window launch and the lobby music playing in the headphones next to me is distracting so I disable the plugin. But then I want to check my environment in VR at the end of the day. Now you need to save everything, close down all instances of UE and reload your project to reload the plugins, then do it again to turn it back off. What is the point of just launching Oculus Home every time anyway if it doesn’t show your project in the headset in non-vr preview mode? Please change this back so the Oculus only loads when I use VR Preview.

4/4/20 and this is still an issue. Can’t open any project without my Oculus starting up. Even ones that don’t use VR. Disabled the plugins for Oculus and Steam. Restarted the engine. Works fine as long as I stay in the project I turned it off for. Reverts back to opening Oculus when I open another project. This is because it is set to start by default for some reason. So I found a workaround for it but you have to do it for every engine version you download.

  1. Open up your file explorer and navigate to: C:\Program Files\Epic Games[ENGINE VERSION]\Engine\Plugins\Runtime\Oculus\OculusVR\OculusVR.uplugin

Note: If your install path is different, then change everything before ‘Epic Games’

  1. Open the *.uplugin file in a text editor and look for the following line: **“EnabledByDefault”: true. **It should be line 13 in Notepad++.

  2. Change “true” to “false”.

Now it shouldn’t start Oculus when you press play.