4.17.2 unreal freezing

Hello,

Since I have installed 4.17.2, Unreal has frozen countless times.

I am on windows 10 x64. There seems to be no way for me to reproduce it as it happens whatever i am doing, in the editor, in the skeleton mode, in blueprint editor.

The program freezes, and does not respond at all, requiring task manager to end the process

Thankyou
Ben Swinbanks

UPDATE:
So after some forum searching, I have since tried turning off Nvidia shadow play. Still freezing :frowning:
I am now installing 4.18.0 to see if the problem persists. This is not an issue I have come across in 4.17.1

Anything in event viewer? Or, the UE4 log files? If you are not using VR, disable all of the VR plugins… Actually, any plugin that you for sure do not need, disable. I do not do Linux or Apple stuff, so I disable anything related to that. Apologies if the above has already been tried…

Oh, did you upgrade your video drivers? That use to cause me no end of pain!

Hey thanks for the reply,
Nothing in the log files but the last operation, which is always different and always worked fine. Theres no easily observable ‘trigger’ to the crash…

I updated my graphics drivers about a week or two before the problems started. The only thing that I can think of is that I upgraded to 4.17.2 and then the problems started. Never a crash, the whole process freezes.

I will be using VR down the line, but atm developing for keyboard and mouse… I will see how 4.18 preview 2 rolls… hopefully something in there fixes it. If not ill start killing plugins.

Cheers!

Hey Swinny_-

Please let us know if you have any freezing in the 4.18 preview. Additionally, does the freeze occur in a specific project or in new projects as well? If it only occurs in a specific project, please try deleting the Saved and Intermediate folders from the project directory. Let us know if you have any additional information that would help me reproduce the behavior you’re seeing locally.

Hi Doug,
The problem was project specific and seemed to be tied up to a specific blueprint. I cleaned it up abit and now things seem to be running smoothly again. Thankyou

Hi Doug,
The problem was project specific and seemed to be tied up to a specific blueprint. I cleaned it up abit and now things seem to be running smoothly again. Thankyou

edit: Sorry guys I really didnt end up finding the actual cause. my code was exteremly inefficient and doing alot of things in construction too. I tore it all out and remade it all nice-like.

not a very illuminating answer but thats about as much detail as I can give sorry guys. good luck :slight_smile:

Hi Swinny, any idea what led you to finding the problem blueprint? Did the Save/Logs give you any clues? Or was it a wild guess?

Can we get some more details? I’m getting an odd and seemingly random Client Freeze on a packaged 4.17 game.

Hi All, I have the same problem, someone discovered the cause? I found several reports (Unreal Engine Issues and Bug Tracker (UE-42280) https://answers.unrealengine.com/questions/716390/shipping-game-random-freeze-stops-responding-with.html https : //answers.unrealengine.com/questions/673724/does-anyone-know-how-to-solve-this-error.html), following some tips have decreased the frequency of freeze, but continues to happen occasionally.

Packaged Game freezing !FEventWin::Wait(unsigned int WaitTime, const bool bIgnoreThreadIdleStats) Line 1158 C++ - Programming & Scripting - Unreal Engine Forums Apparently its in 4.18 as well.

What seemed to be the problem with this Blueprint? Is it AI related? I’m having a similar issue, can’t figure it out.

Thanks Michael, I will look into it.