4.17.2 being super slow/unresponsive

I tried to open a project and at first it loads up pretty quickly but then it just went reeaaallly slow all of a sudden. Once it loads up it says ‘finished asset discovery’ and sometimes the textures are kinda blurry. I even left it alone for almost 20 minutes to see if it just needed to load but nothing. I’ve closed any other programs to see if those affected it, and also tried restarting.
I’ve also tested on 4.18.2, issue persists. Then I uninstalled the engine and the launcher and re-downloaded them but keep getting the same problem.
I tried the same project on a few different computers at my uni and it works fine.

Also, just to make sure it wasn’t just my project I tried to create a new one. Once it got to the load project/create new screen the same thing happened.

It says the shaders are compiled and asset discovery is finished but the numbers for those are way higher than what it should be. In my project folder I apparently have around 350 assets but the asset discovery states around 2000

My specs are:
R9 390 8gb
8gb RAM

(it worked perfectly fine around November which was the last time I used UE4 before recently)