Download

4.17.2 and Xcode

Ok. I am a bit confused… It says that the Xcode 9 issues are resolved in 4.17.2. However, I still get this error…

Screen Shot 2017-10-02 at 9.23.31 AM.png

So, I can’t use 4.18 yet, because there isn’t a way to add the Marketing image and the icons don’t go into the project (and it isn’t released, yet lol)… But, I can’t use 4.17.2 because it says it needs 8.3.3

But, if I do use 8.3.3, it says that the metal compiler is too old…

If I use the source version of 4.17.2, it says that Xcode isn’t even installed. Although, I obviously used it to compile it…

I have wiped the computer and installed every combination of OS, Xcode, and UE. I now have a project in the final TestFlight stages and I can’t move forward.

I was fine with 4.16.3 a week or so ago, however I couldn’t get it to only add the ARM64 slice, even though I only had the ARM64 items selected.

I will totally take the blame for not reading something or setting something up wrong, but what was/is it? I just want to get my app on the store now, somewhere under 150MB.

I removed all the plugins I wasn’t using, I am doing a full rebuild, a pak, compressed, no engine content, no pre-req’s… Etc…

I did get it to compile with a file size of 95MB, but iTunes said that it didn’t have the CFBundleIconName set. I added it in the additional .plist and it still didn’t work. I am just confused.

What am I supposed to be using at this time?

If anyone has the trifecta and cares to share let me know! OS version, Xcode version, and UE version (source or launcher). Thanks in advance!

Ok. I got this worked out. I am currently using macOS 10.12.6, Xcode 8.3.3, and UE 4.17.2 (Launcher). This was after a complete wipe and reinstall of the OS. There were still some craziness with the project upgrade, but starting a new project and migrating the maps fixed most of that. Just wanted to update this thread, in case someone else was running into this.

You can have installed two versions of Xcode at the same time. 8.3.3 and 9.0.0. You can download archived version from Apple Developer portal.

Thanks! I did try that, however, I got an error saying that Xcode wasn’t installed. I can’t remember exactly which combination gave me that, but I was told that it had something to do with Xcode not being directly in the applications folder. I want to say that I was using the Github version. Which I found odd, since I used Xcode to compile it, but then it wouldn’t find it. I did set the Xcode -select -switch to use that version…

I am also running into this issue. I need Xcode 9 installed because of other dev work I’m doing, but I also have 8.3.3 installed. How do I point UE 4.17.2 to the correct version of Xcode for the project? Is this configurable somewhere? I really want 9 in the Applications folder because that’s where a lot of tools expect it to be.