4.17.1 Binding content to Text UI widgets do not work in standalone game (works editor and in 4.16.3)

Pardon that I am still fairly new to developing with Unreal 4 but I’m pretty sure this is a bug I’ve encountered between versions. My tests show clear differences in behavior between 4.17 and 4.16 show there is a difference in behavior.

I’m experiencing that binding text UI widgets, when trying to dynamically change the displayed strings, works in editor but not when I try in the “standalone game” play option.

I’ve simplified my larger project into this easy reproducible scenario. It is unclear if there are any other binding issues as this was the only scenario I’ve tried.

Repro Steps:

  1. Create a new empty project with 4.17.1
  2. Create a new asset User Interface > Widget Blueprint
  3. Edit the new widget and drop a Simple Static Text Widget into the CanvasPanel
  4. Of the Text widget name the Content>Text “Test Block” (or anything really);

212269-step4.png

  1. Created a binding for Content>Text; open the graph and set the text to “Changed” (or anything different) as the node output.

212265-step5.png

  1. Create and save an empty map to use.
  2. Open the Level Blueprint for the map.
  3. In the blueprint: From ‘Event BeginPlay’ link up the following nodes: Create Widget (Set the class to the Test widget asset that was created); Then create a Add to Viewport node wired off the result of Create Widget taking the return value of Create Widget as the Target object.

  1. Save all and play editor…
    Observe the text displays as “Changed”

212267-step9.png

  1. THE BUG: Play in Standalone Game…
    Observe the text is blank, presumed output as an empty string.

212268-step10.png

  1. To validate it is a problem with binding, unlink the binding… Observer the text does display the original text in the Play in Standalone game.

  2. Repeat steps 1-10 with version 4.16.3… Observer there is no bug at step 10 on the older Unreal Engine version; “Changed” is displayed as expected.

Actual Results:
UI text widgets content bound in 4.17 do not display in Standalone games; but do correctly in 4.16

Expected Results:
Behavior is identical between 4.17 and 4.16; all text binding set and display the expected output in standalone builds.

Hi MidknightDev:

Thank you for your report. I was able to reproduce the issue in 4.17.1 and did notice that it is not present in 4.16.3. I have logged the issue, which you can track through this link: Unreal Engine Issues and Bug Tracker (UE-49348)

Let me know if there is anything else that I can help you with.

Sincerely,

Natalia