4.16 crashes every time i open my level

4.16 crashes every time i open my level. I upgraded this level from 4.15 to 4.16. Its instant crash every time i try to open it.

The level itself is just a level with like 20 sublevels within it. All the sublevels seem to open fine on their own 1 by 1…


I attempted to create a new persistant level and add all sublevels to that persistant level. I hit save all, closed the editor and relaunched it. When i opened up the new persistant level… that level crashes as well … instant crash.

This makes no sense. All sub levels open up seperately with no problems… so what gives??? How do i fix this… My work has come to a stand still now… this is scary. PLEASE HELP.


I cant even right click or select → delete … a persistant level that contains the sublevels… So yea… cant open, delete, or right click the persistant level… all things crash unreal instantly… great…

Can you post the crash log you are getting?

i’m not sure if this works, first make a backup file, then right click your Unreal Engine Project file change Unreal engine Version to where it works before.


why would i want to do that? I want to use unreal engine 4.16.
It works fine in 4.15 already.

Your project is hitting an Assert( ) in a Serialize( ) function:

check(Ar.Tell() < MAX_SUMMARY_SIZE / 2); // we need to be sure that we can at least get the size from the initial request. This is an early warning that custom versions are starting to get too big, relocate the total size to be at offset 4!

The bad news is that I don’t have any information from the logs about what level is causing the issue. This could also be a bug when it comes to upgrading from 4.15 to 4.16.

In the past, when I have worked on issues like this, I have used Visual Studio to run the editor and let the project hit the crash, so I could use the debugger to see the exact data that is having the issue, which is my recommendation to you.

well with 4.15 you could test and add a new persistant level. then if it crashes, there must be a hardware issue. if not, there’s probably compatibility issue with 4.16

Im not a programmer… i dont know how to do any of that. And even if I find the level causing it… how do i fix it? I dont want to toss aside my valuable time.

The level works in 4.15 just fine.

Any idea on what that error message actualy means? Something i shoudl be looking for?

4.15 doesnt have any issue like this. Ive been workn on thsi project for years… through many engine versions.

My assumption is that one of your levels has some level of corruption in it, causing an issue when moving to 4.16. Because that is impossible to know for sure, I really can’t say what it might be.

The best thing I can offer is that if you want to upload and send your project, I can look at it in 4.16 and see if I see the same issue. If you can’t or don’t want to send your project, I would suggest trying to find somebody who can help you debug in Visual Studio. If you do want to upload your project, you can PM me on the forums:


We could try that, though the file is huge in size. Asside from that… every level opens seperately… And i have tried adding all levels now to a new persistant level and i deleted all levels that are unused. Everything loads up fine in the persistant level. But then i hit save all. Close the editor… and reopen this brand new persistant level… again instant crash.

Doesnt make sense…

I agree, there is something going on when you complete those steps with the content you have. I can’t say what because it is a complex system and there is just too much going on to understand it from this viewpoint.

Hi kurylo3d.

Another user also reported this crash: https://answers.unrealengine.com/questions/604280/416-cannot-load-maps-with-many-sub-levels.html

And we have logged a ticket for the issue: Unreal Engine Issues and Bug Tracker (UE-45563)

Our developers will review the issue.