4.16.1 Dev build app crashes on start "unfortunately [App] has stopped" on android

Hi PlatinumBlade,

A number of us have been trying to reproduce this for two days and have not had any luck with a variety of devices. Also 4.16.1 passed our testing without seeing this error. So I think this issue is affecting a only subset of our users but I’m not sure what the difference is yet.

Could you tell me what NDK toochain version are you using? I’m using r12b.

Would you be able to send me the adb logcat output of a launch / crash?

What device are you testing on?


Hi JackP,

I’m using Unreal Engine 4.16.1. When I installed it I also installed the android files from the EXTRAS Folder of the Engine so I’m using R12B aswell.

I’m having three different problems when I upload my projects to Play Store:

1- If I package my project with minimum API 24 and Target 24 (in order to support VULKAN) and changing the sdk and ndk version to “latest”; when I publish to the store it gives to Nougat based Devices a “XAPK VALIDATION FAILED”, but all the files downloaded from the store are correct, the apk installed correctly and the OBB file is in the device aswell, so i don’t understand why this happens!

1.1- If I package my project with minimum API 21 and Target 23 (supporting only ES2 and ES3.1) and changing the sdk to API 23 and ndk to 21, everything works fine and well so nos problems in this part.

You can reproduce this problems by downloading two of my games from the store on nougat devices and marshmallow devices to see the difference:

Game 1: https://play.google.com/store/apps/details?id=com.lightrunnerthegame.lightrunner&hl=pt_PT

Game 2: https://play.google.com/store/apps/details?id=com.PlatinumBladeGames.EpicAdventureArcadeShooter&hl=pt_PT

2- This problem can be included in the Problem 1 Section because from 4.16.1, every game I package for API 19 and below simply won’t work and yes, I checked multiple times and my android files and the engine and environment variables are all working and correctly installed. So it’s strange only API 21+ games can run.

3- This is specific only to one of my projects, It goes into the splash screen and then it crashes and closes:
You can test and see problems by downloading the app to your testing devices:

That’s all for now. I hope you can help!

Hi PlatinumBlade,
for point 2:
I downloaded this on a 4.4.2 (api 19) device and it ran fine. It downloaded version 1.1.1. version 1.1.2 wont install on the device due to it being targetted at API 24.

Can you attach the output log generated whilst packaging your app and if possible a logcat capture from the device as it fails?

Hi AllanBentham,

I presume you are talking about my game posted at Point 3 and not any of the two from Point 1.

I may extend Point 3 by saying that it does not work on any version, being it 19, 21, 23, 24, etc. It simply won’t work anywhere.

Because of this, for testing purposes I put the new version on Developer Consoles targeted for API 21+ and reuploaded the last functional version where everything worked even for API 19 and below.

For the Output log you are asking me, Im packaging for Minimum 21 and Target 23.

link text

Ah, I see, i misunderstood. For point 3, the logcat looks like there are some mediaplayer issues just before it exits. Are you running with cyanogen or a stock rom? If it is a cyanogen rom are you able to repro and capture the logcat again from a device running a stock rom?
for point 2, could you get us a logcat from an api 19 device that fails?

I’m using the stock Rom from my Xperia Z3 on Marshmallow.
I’m sorry but I don’t have access to an api 19 or below device :confused:


Sorry for the late reply. The two devices, both stock, I could replicate the issue on were:

  1. Blu Life Pure - Android version 4.2.1
  2. Alcatel One Touch Fierce - Android version 4.2.2

I am unable to provide logcats for now but will try to in the near future if necessary.

Thank you very much! I hope PlatinumBlade’s issue is also resolved, but this seems to be it for me.

Don’t bother with that…
I mean, I’m sorry that I did not notify earlier but yesterday I created a new project based on the 2D template from UE4 and moved all my UltraCookieClicker assets/files to this new project, somehow the game now works on every device I tested including my Z3.
This concludes that there is nothing wrong with Z3 and that bug ticket you submited for the Z3 can be ignored.
It is strange that the game was not working in the first place but that problem is now solved.
Thanks for all the support.

Oh, one more thing, I have another thread on AnswerHub that, in my opinion, needs special attention by the Android Development team of UE4.

Part of that is now solved because of what you answered below with UE-46539, so now my problem with XAPK Validation remains.

You can get more details here:

I apreciate all the help, thanks! Have a great day!

After downloading 4.16.1 and updating codeworks from the extras folder, dev build apps installed on my phone from the batch file crash immediately displaying “Application Error unfortunately [App] has stopped”. Everything worked on 4.14.3

I started a new blueprints third-person project, optimized for mobile and scalable graphics.

The only changes I made in the project settings was to configure for android and google play(because it’s red and red means bad)

Otherwise the ndk is set to android-19. I tried both ‘latest’ and ‘matchndk’ for the sdk setting to no avail.

I also tried packaging with and without an OBB file to no avail.

I’m also having this problem on Android versions below 21 and tried exactly as you described too! All my 4 android games built on 4.16.1 work perfectly but only API level 21+. This version of the Engine is very problematic from my experience. I never had any of this problems on 4.15.

I’m sorry but I didn’t find any solution… If I can get my games to work again on API 19 and below on 4.16.1 I will notify you.

Hi guys,

Thanks for the report and I’m sorry for the inconvenience. We are working on this bug now and hope to have a fix for it in 4.16.2. The issue is being tracked with ticket number UE-46353 (the public tracker link should be visible soon).


Hi PlatinumBlade, we can also see your UltraCookieClicker game crashing on a stock Xperia Z3, and we’ve got a ticket UE-46582 (public link should be visible soon) to investigate problems with this device.

Hi Rez Nov,

We think the issue you’re seeing is different to the one reported by PlatinumBlade. Do you have some more information about the device you’re using and adb logcat output from a launch/crash? It would be very useful in helping track this down.


Hi Rez,

Thanks for the reply. Your Android versions you’re seeing this with means you’re probably running into issue UE-46539.

The fix will be in a 4.16.3 when we create it and in 4.17, but if you’re using source code the fix is easy to apply yourself.

In Engine\Source\Runtime\Renderer\Private\VolumetricFog.cpp you need to replace the two calls to exp2 with FMath::Exp2 and three calls to log2 with FMath::Log2. Android prior to version 4.4.x do not include these functions in the standard library and that is causing the crash on startup.


Hi PlatinumBlade,

We can reproduce the crash with your UltraCookieClicker game from google play on a stock Xperia Z3, but we’ve been unable to reproduce with our own sample projects using either 4.16 or our upcoming 4.17 code.

It would be very helpful to us if you could send us a sample project which crashes on the Z3 so we can track down the cause of the problem and fix it.

If that is possible, could you upload a zip file to a cloud storage provider and please send me a link by email to jack.porter at epicgames.com?