Download

4.15 Dedicated server not running

Having some issues running a dedicated server on 4.15. I changed things over to be the same as ShoooterGame, and I had it running before, but now it doesn’t seem to run properly. I package up my game, build the server executable, and move it over to my packaged game and this is what I get when I run it.


Log file open, 02/17/17 23:21:43
LogPlatformFile: Not using cached read wrapper
LogInit:Display: RandInit(-43480093) SRandInit(-43480093).
LogTaskGraph: Started task graph with 5 named threads and 9 total threads with 1 sets of task threads.
LogStats: Stats thread started at 0.067777
LogInit: Using libcurl 7.47.1
LogInit:  - built for x86_64-pc-win32
LogInit:  - supports SSL with OpenSSL/1.0.2g
LogInit:  - supports HTTP deflate (compression) using libz 1.2.8
LogInit:  - other features:
LogInit:      CURL_VERSION_SSL
LogInit:      CURL_VERSION_LIBZ
LogInit:      CURL_VERSION_IPV6
LogInit:      CURL_VERSION_ASYNCHDNS
LogInit:      CURL_VERSION_LARGEFILE
LogInit:      CURL_VERSION_IDN
LogInit:  CurlRequestOptions (configurable via config and command line):
LogInit:  - bVerifyPeer = false  - Libcurl will NOT verify peer certificate
LogInit:  - bUseHttpProxy = false  - Libcurl will NOT use HTTP proxy
LogInit:  - bDontReuseConnections = false  - Libcurl will reuse connections
LogInit:  - CertBundlePath = nullptr  - Libcurl will use whatever was configured at build time.
LogOnline:Display: STEAM: Loading Steam SDK 1.32
LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
LogInit: Build: ++UE4+Release-4.15-CL-0
LogInit: Engine Version: 4.15.0-0+++UE4+Release-4.15
LogInit: Compatible Engine Version: 4.15.0-0+++UE4+Release-4.15
LogInit: Net CL: 0
LogDevObjectVersion: Number of dev versions registered: 14
LogDevObjectVersion:   Dev-Blueprints (B0D832E4-1F89-4F0D-ACCF-7EB736FD4AA2): 8
LogDevObjectVersion:   Dev-Build (E1C64328-A22C-4D53-A36C-8E866417BD8C): 0
LogDevObjectVersion:   Dev-Core (375EC13C-06E4-48FB-B500-84F0262A717E): 2
LogDevObjectVersion:   Dev-Editor (E4B068ED-F494-42E9-A231-DA0B2E46BB41): 14
LogDevObjectVersion:   Dev-Framework (CFFC743F-43B0-4480-9391-14DF171D2073): 22
LogDevObjectVersion:   Dev-Mobile (B02B49B5-BB20-44E9-A304-32B752E40360): 0
LogDevObjectVersion:   Dev-Networking (A4E4105C-59A1-49B5-A7C5-40C4547EDFEE): 0
LogDevObjectVersion:   Dev-Online (39C831C9-5AE6-47DC-9A44-9C173E1C8E7C): 0
LogDevObjectVersion:   Dev-Physics (78F01B33-EBEA-4F98-B9B4-84EACCB95AA2): 0
LogDevObjectVersion:   Dev-Platform (6631380F-2D4D-43E0-8009-CF276956A95A): 0
LogDevObjectVersion:   Dev-Rendering (12F88B9F-8875-4AFC-A67C-D90C383ABD29): 12
LogDevObjectVersion:   Dev-Sequencer (7B5AE74C-D270-4C10-A958-57980B212A5A): 3
LogDevObjectVersion:   Dev-VR (D7296918-1DD6-4BDD-9DE2-64A83CC13884): 0
LogDevObjectVersion:   Dev-LoadTimes (C2A15278-BFE7-4AFE-6C17-90FF531DF755): 1
LogInit: Compiled (64-bit): Feb 17 2017 14:49:25
LogInit: Compiled with Visual C++: 19.00.24215.01
LogInit: Build Configuration: Development
LogInit: Branch Name: ++UE4+Release-4.15
LogInit: Command line: -log
LogInit: Base directory: C:/builds/WindowsNoEditor/TDS/Binaries/Win64/
LogInit: Installed Engine Build: 0
LogInit: Presizing for max 2097152 objects, including 0 objects not considered by GC, pre-allocating 0 bytes for permanent pool.
LogStreaming:Display: Async Loading initialized: New Async IO: true, Event Driven Loader: true, Async Loading Thread: false
LogInit: Object subsystem initialized
[2017.02.18-05.21.43:793]  0]LogInit: Selected Device Profile: [WindowsServer]
[2017.02.18-05.21.43:793]  0]LogInit: Applying CVar settings loaded from the selected device profile: [WindowsServer]
[2017.02.18-05.21.43:797]  0]LogInit: Computer: LATTA-MAIN
[2017.02.18-05.21.43:797]  0]LogInit: User: Null
[2017.02.18-05.21.43:798]  0]LogInit: CPU Page size=65536, Cores=6
[2017.02.18-05.21.43:798]  0]LogInit: High frequency timer resolution =3.513591 MHz
[2017.02.18-05.21.43:798]  0]LogMemory: Memory total: Physical=31.9GB (32GB approx)
[2017.02.18-05.21.43:799]  0]LogMemory: Platform Memory Stats for WindowsServer
[2017.02.18-05.21.43:799]  0]LogMemory: Process Physical Memory: 108.71 MB used, 108.71 MB peak
[2017.02.18-05.21.43:799]  0]LogMemory: Process Virtual Memory: 124.05 MB used, 124.05 MB peak
[2017.02.18-05.21.43:799]  0]LogMemory: Physical Memory: 14133.39 MB used,  18545.57 MB free, 32678.97 MB total
[2017.02.18-05.21.43:800]  0]LogMemory: Virtual Memory: 412.36 MB used,  18545.57 MB free, 134217728.00 MB total
[2017.02.18-05.21.43:830]  0]LogTextLocalizationManager: No specific translations for ('en-US') exist, so ('en') translations will be used.
[2017.02.18-05.21.43:949]  0]LogAssetRegistry: FAssetRegistry took 0.0270 seconds to start up
[2017.02.18-05.21.43:951]  0]LogPackageLocalizationCache: Processed 3 localized package path(s) for 2 prioritized culture(s) in 0.002325 seconds
[2017.02.18-05.21.43:969]  0]LogTemp:Warning: game session constructor
[2017.02.18-05.21.43:984]  0]LogBlueprintUserMessages:Warning: DEBUG: LocalNotification DefaultPlatformService NOT FOUND
[2017.02.18-05.21.43:986]  0]LogInit: Selected Device Profile: [WindowsServer]
[2017.02.18-05.21.43:992]  0]LogNetVersion: GetLocalNetworkVersion: CL: 0, ProjectName: tds, ProjectVersion: , EngineNetworkVersion: 2, GameNetworkVersion: 0, NetworkChecksum: 1920712341
[2017.02.18-05.21.44:003]  0]LogUObjectArray: 28755 objects as part of root set at end of initial load.
[2017.02.18-05.21.44:003]  0]LogUObjectAllocator: 6028224 out of 0 bytes used by permanent object pool.
[2017.02.18-05.21.44:004]  0]LogUObjectArray: CloseDisregardForGC: 0/0 objects in disregard for GC pool
[2017.02.18-05.21.44:004]  0]LogModuleManager:Warning: ModuleManager: Module 'XAudio2' not found - its StaticallyLinkedModuleInitializers function is null.
[2017.02.18-05.21.44:029]  0]LogEngine: Initializing Engine...
[2017.02.18-05.21.44:031]  0]LogStreaming:Warning: Export 1 (MaterialExpressionVectorParameter0) in ../../../Engine/Content/EngineDebugMaterials/DebugMeshMaterial.uasset was not created.
[2017.02.18-05.21.44:031]  0]LogStreaming:Warning: File ../../../Engine/Content/EngineDebugMaterials/DebugMeshMaterial.uasset had 1k of exports we never loaded.
[2017.02.18-05.21.44:032]  0]LogStreaming:Warning: Export 1 (MaterialExpressionTextureSample_1) in ../../../Engine/Content/EngineMaterials/M_InvalidLightmapSettings.uasset was not created.
[2017.02.18-05.21.44:033]  0]LogStreaming:Warning: File ../../../Engine/Content/EngineMaterials/M_InvalidLightmapSettings.uasset had 1k of exports we never loaded.
[2017.02.18-05.21.44:034]  0]LogStreaming:Warning: Export 1 (MaterialExpressionVectorParameter_4) in ../../../Engine/Content/EditorMaterials/GizmoMaterial.uasset was not created.
[2017.02.18-05.21.44:034]  0]LogStreaming:Warning: File ../../../Engine/Content/EditorMaterials/GizmoMaterial.uasset had 1k of exports we never loaded.
[2017.02.18-05.21.44:035]  0]LogStreaming:Warning: Export 1 (MaterialExpressionScalarParameter_0) in ../../../Engine/Content/EngineMaterials/PhAT_JointLimitMaterial.uasset was not created.
[2017.02.18-05.21.44:036]  0]LogStreaming:Warning: Export 2 (MaterialExpressionVectorParameter_0) in ../../../Engine/Content/EngineMaterials/PhAT_JointLimitMaterial.uasset was not created.
[2017.02.18-05.21.44:036]  0]LogStreaming:Warning: File ../../../Engine/Content/EngineMaterials/PhAT_JointLimitMaterial.uasset had 1k of exports we never loaded.
[2017.02.18-05.21.44:039]  0]LogInit: Texture streaming: Disabled
[2017.02.18-05.21.44:043]  0]LogInit:Display: Game Engine Initialized.
[2017.02.18-05.21.44:043]  0]LogInit:Display: Starting Game.
[2017.02.18-05.21.44:043]  0]LogNet: Browse: /Game/Maps/MainMenuMap?Name=Player
[2017.02.18-05.21.44:044]  0]LogLoad: LoadMap: /Game/Maps/MainMenuMap?Name=Player
[2017.02.18-05.21.44:056]  0]LogMemory: Platform Memory Stats for WindowsServer
[2017.02.18-05.21.44:056]  0]LogMemory: Process Physical Memory: 164.61 MB used, 169.70 MB peak
[2017.02.18-05.21.44:057]  0]LogMemory: Process Virtual Memory: 155.58 MB used, 161.21 MB peak
[2017.02.18-05.21.44:057]  0]LogMemory: Physical Memory: 14195.30 MB used,  18483.66 MB free, 32678.97 MB total
[2017.02.18-05.21.44:057]  0]LogMemory: Virtual Memory: 462.59 MB used,  18483.66 MB free, 134217728.00 MB total
[2017.02.18-05.21.44:057]  0]LogMemory: 
[2017.02.18-05.21.44:058]  0]Allocator Stats for binned2: (not implemented)
[2017.02.18-05.21.44:063]  0]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2017.02.18-05.21.44:139]  0]LogWindows:Error: === Critical error: ===
[2017.02.18-05.21.44:140]  0]LogWindows:Error: 
[2017.02.18-05.21.44:140]  0]LogWindows:Error: Assertion failed: !bCheckAdded || NodeRef.bAddedToGraph [File:C:\UnrealEngine\Engine\Source\Runtime\CoreUObject\Public\Serialization/AsyncLoading.h] [Line: 248] 
[2017.02.18-05.21.44:141]  0]LogWindows:Error: 
[2017.02.18-05.21.44:141]  0]LogWindows:Error: 
[2017.02.18-05.21.44:142]  0]LogWindows:Error: 
[2017.02.18-05.21.44:142]  0]LogWindows:Error: KERNELBASE.dll!0x0000000022327788
[2017.02.18-05.21.44:143]  0]LogWindows:Error: TDSServer.exe!0x000000008E97F7AA
[2017.02.18-05.21.44:143]  0]LogWindows:Error: TDSServer.exe!0x000000008E7A898A
[2017.02.18-05.21.44:143]  0]LogWindows:Error: TDSServer.exe!0x000000008E72FAB8
[2017.02.18-05.21.44:144]  0]LogWindows:Error: TDSServer.exe!0x000000008E9E6A90
[2017.02.18-05.21.44:144]  0]LogWindows:Error: TDSServer.exe!0x000000008EA4686D
[2017.02.18-05.21.44:145]  0]LogWindows:Error: TDSServer.exe!0x000000008EA0783E
[2017.02.18-05.21.44:146]  0]LogWindows:Error: TDSServer.exe!0x000000008E9E36AF
[2017.02.18-05.21.44:146]  0]LogWindows:Error: TDSServer.exe!0x000000008EA22B0E
[2017.02.18-05.21.44:146]  0]LogWindows:Error: TDSServer.exe!0x000000008EA295DB
[2017.02.18-05.21.44:147]  0]LogWindows:Error: TDSServer.exe!0x000000008EA4A1CF
[2017.02.18-05.21.44:147]  0]LogWindows:Error: TDSServer.exe!0x000000008EA49338
[2017.02.18-05.21.44:148]  0]LogWindows:Error: TDSServer.exe!0x000000008EA0FCA5
[2017.02.18-05.21.44:149]  0]LogWindows:Error: TDSServer.exe!0x000000008EB9F3AA
[2017.02.18-05.21.44:150]  0]LogWindows:Error: TDSServer.exe!0x000000008EB9EC19
[2017.02.18-05.21.44:150]  0]LogWindows:Error: TDSServer.exe!0x0000000090F2699D
[2017.02.18-05.21.44:150]  0]LogWindows:Error: TDSServer.exe!0x0000000090EE216F
[2017.02.18-05.21.44:151]  0]LogWindows:Error: TDSServer.exe!0x00000000907FBF1A
[2017.02.18-05.21.44:152]  0]LogWindows:Error: TDSServer.exe!0x000000008E54A304
[2017.02.18-05.21.44:152]  0]LogWindows:Error: TDSServer.exe!0x000000008E549862
[2017.02.18-05.21.44:153]  0]LogWindows:Error: TDSServer.exe!0x000000008E5499DA
[2017.02.18-05.21.44:153]  0]LogWindows:Error: TDSServer.exe!0x000000008E558E48
[2017.02.18-05.21.44:153]  0]LogWindows:Error: TDSServer.exe!0x0000000092289A9B
[2017.02.18-05.21.44:154]  0]LogWindows:Error: KERNEL32.DLL!0x0000000023738364
[2017.02.18-05.21.44:154]  0]LogWindows:Error: ntdll.dll!0x0000000025E870D1
[2017.02.18-05.21.44:154]  0]LogWindows:Error: ntdll.dll!0x0000000025E870D1
[2017.02.18-05.21.44:155]  0]LogWindows:Error: 
[2017.02.18-05.21.44:163]  0]LogExit: Executing StaticShutdownAfterError
[2017.02.18-05.21.44:164]  0]LogWindows: FPlatformMisc::RequestExit(1)
[2017.02.18-05.21.44:164]  0]Log file closed, 02/17/17 23:21:44


I looked a bit into it but doesn’t seem like there’s much info out there for this problem. Any help would be appreciated, thank you!

A quick way to fix this is unchecking “Event Driven Loading Enabled” in Streaming section and packaging again. Im not sure of the repercussions of this just yet but i can continue deploying my servers like this

I was suffering with the same issue and this fixes it. It’s also Event not Even, just want it to be abundantly clear for people that are getting this issue.

This bug also bit me, took a bit to figure out, was enabled by default in my project. I can’t seem to find any official documentation about what the Event Driven Loader is, can anyone provide any links?

Has anyone made a bug report yet?

Just experienced the same “bug” ? I have no idea what “Event Driven Loading Enabled” does, but unchecking it worked for me as well.

Hi! I ran into the same problem and i can confirm that unchecking “Event Driven Loading Enabled” fixed it (4.15 release).

confirming this fixed it for me as well :slight_smile:

Same problem here, thank you so much guys! was doing my head in! :smiley: :slight_smile:

This is a bug in that case, make sure to report it on Answerhub or it’ll never get fixed :slight_smile:

I experienced this problem on Win64 Dedicated Server as well and unchecking “Event Driven Loader Enabled” fixed the problem.

For reference, Doug Wilson (Epic Staff) did submit a bug. You can find it here: https://issues.unrealengine.com/issue/UE-42742