4.15.0 p4 animations do not play after packaging

I am using 4.15 p4 and after packaging the game, my character does not play any animations stays on T pose, BUT can get the anim_notifies, and play a sound.

before 4.15 everything was perfect, now the animations do not show on packaged build.

Standalone and Editor works perfectly

Hi BagmanPT,

Did you make a copy in UE4.15Preview and keep the original in the Version it was created in? If not, moving forward this is best practice as changes between versions are not compatible as bugs are fixed and new features added etc.

That said, there is likely a communication breakdown between the Character Blueprint and Animation Blueprint which can occur in the CharacterBP settings as a result of directories in different locations between engine versions. To fix:

  1. Make a back-up of your Project Folder, then your project folder remaining in “Unreal Projects,” delete the Intermediate and Saved folders
  2. Right-click on the Contents folder and select “Fix up” redirectors
  3. In your Character BP, select/reapply the appropriate Animation BP even if it is currently selected, in which case, deselect it, then re-select it. Save changes. The preview in the CharacterBP should change from T-pose to the appropriate idle pose. (Do this step even if preview is not T-pose to ensure directory links are updated)
  4. If this fails, re-check your AnimBP to make sure the Animations are still linked appropriately. Fix as needed.
  5. Save all.

You may also want to check your World Settings to make sure the proper pawn and game made are selected.

Let me know if this does not resolve your issue.



1: I did make a back-up when moving up to 4.15 but I messed too much and long story short, I dont have a backup now…

2: Did “fix up” as you said, still the same thing came up

3: Also did this, more times than I can count…

4: Did it and also remade the connections on the Enums, that were previously reset because of 4.15 preview 2,

5: check

Did everything as you said, and it did not fixed. Still same thing, editor and standalone works perfectly… packaged game does not.

Ok so this is the setup:

I am building on the GenericShooter template. Been doing it since 4.6/4.7
and upgrading every step of the way, everything worked without any problem until 4.13 which gave me a problem with spawns and I had to wait for 4.14, 4.14 came and I had yet another problem related to that, 4.15, preview 1, 2 and 3 gave me all errors regarding enums, Async loading, and other packaging errors, enums have been messed on preview 2 but I’ve redone it so it worked as intended, preview 4 came out, and I finally managed to package the game.

4.15 preview 4 came and I packaged the game, everything went smooth and when testing the game, my character has a T pose with a -90 rotation, standing in the air… (see attachments, one is in editor/standalone the other one is the game packed. same skeleton, same parameters, same map even)

Everything in the editor works perfectly, standalone works perfectly as well, and when packaging the game, the character just resets, puts itself in -90 rotation and T pose.

Also the AnimBP works in the packaged game since I can hear the footsteps which are called from the AnimBP with the anim_notify on the animations. that is working. Its just not applying the Animations on the skeleton.

ALSO need to mention: I am using a BP_playerCharacter as a parent, and I am using several children BP as different character.

Have you tried using the parent as the player character? (If you haven’t already, please try this.) Does the parent work and not the children or do both parent and children display this same behavior?

Ok, good news. Using the Parent BP works flawlessly, although I don’t have the different behavior that the children had.
Done reparenting and creating new child blueprints. same thing, T pose, no animations. The problem is definitely related to the children/parent connection…

any ideas?

Try making an entirely new child BP from the working parent and see if this does not resolve the issue.

If not, in your Child AnimBlueprints, are you using animation overrides? If so, are you using animations from AnimSets that are not yet compatible with UE4.15 like from the Movement Animset Pro?

Also, if you are using animations from the Animation Starter Pack, you may want to add and replace the current animations with the latest versions. To do this, move current animations to a folder marked “x.” Add the Animation Starter Pack to your project per the usual, default location. Delete the animations you are currently using and, when prompted, replace with the ones you’ve just imported.

Let me know if this does not resolve the issue.

I already did try making a new child BP, same thing.

The children BP are using the same animset, same thing, mostly what changes are the variables of defence, health, weapons equipped, the 3d model, etc.

Are you telling me that the anims are not compatible from older engine versions? because if I use the parent BP, everything works perfectly, even with different models using the same skeleton. the anim notifies are being triggered aswell. but if I use the child blueprint nothing works. so I dont think that might be the problem. I might be wrong though…

If the animations work with the parent, they should work with the Child. I just noticed the Movement Animset Pro was not compatible, so if you were overriding in the child BP with these I thought it could be the issue. Since that is not the case, we will look into this further.

Ok, so this is what I did so far.

  • Reparented the children BP I had.
  • Created NEW child BP from the parent
    that was working.
  • I even created a child BP that was
    completely the same as the parent,
    without changing any variable or any

anyway that I look at it, only the parent works, if I use a child with everything exactly the same it does not work.

It did not happened before 4.15, this is a new thing, and I did not change any parameter on the player BP to make it not work as intended, the BPs are exactly the same to the ones I had on 4.12 and 4.13, I never tested it on 4.14

UPDATE: I found this on the Logs… I dont know if its helpfull

LogBlueprintCodeGen:Display: Nativization Summary - AnimBP:

UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.02.15-23.03.42:286][ 0]LogBlueprintCodeGen:Display: Name, Children, Non-empty Functions (Empty Functions), Variables, FunctionUsage, VariableUsage

UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2017.02.15-23.03.42:286][ 0]LogBlueprintCodeGen:Display: Nativization Summary - Shared Variables From Graph: 0


I managed to “band aid” the problem.
on the Construction script on the children BP I manually set the anim class, location and rotation. this works somewhat, but if I do any movement related stuff like jump or crouch it resets the location of the player.

This should not happen, is should use all the references from the parent BP. and it only started doing this on 4.15, before that (since 4.7) I never had any issues with this. I also never changed anything related to animation of the character for a long time, so I am sure it was not something I did that changed something

I tried to repro this by going back to an old animation testbed from 4.13, creating a child AnimBlueprint from the original AnimBlueprint in the Animation Starter pack and changing animations in the Asset Override Editor.

I changed the player character to the child AnimBlueprint then updated the project to UE4.15. It played in Editor correctly, so I packaged it for Windows 64 where it continued to work as expected. If this is not an accurate representation of how to reproduce the isssue, would you be willing to share your project for debugging purposes?

If so, please send a link to your zipped file to me in a Private Message on our . This will not be shared publicly and used for the sole purpose of identifying the bug in order to fix it.

Your cooperation in resolving this issue is greatly appreciated,


I am really sorry I might have said things in a way you did not fully understand.

I am not using a animBP child. I am using a BP_playerCharacter child.

I have for a base template the Generic shooter from Gamemakin LLC.
It has a BP_playerCharacter that is used for everything. But since I wanted different classes for different players I managed to make a selection screen where you can select different characters that do different stuff (using BP_playerCharacter_children) and all of them are getting the animation and variables from the BP_playerCharacter parent. the AnimBP is the same for all of them, that does not change at all.

but When I select a class to use the BP_playerCharacter parent instead of the children all works perfectly, like it’s supposed to. but If I select BP_playercharacter_Child_5 (for example) it does not do any animation at all, the skeleton is on T pose and does not do any animation, but like I said, I manage to do a “Band Aid” by setting the animation manually on the construction script of every single BP_playerCharacter_child. (Picture of the “band aid fix” as attachment.)

It does work mostly with what I want, but still, its not picking the animBP of the parent, also the location is reset too. that never happened before.

We are looking into this… Please provide the entire log from where you posted the information from the logs earlier. Also, if you do not want to provide your entire project, could you migrate the parent and 1 child character BP to a blank project and send a link to the zipped project to me on our ? This would help a lot -thanks!