4.15.0 (Bug) Steam achievements do not work after delete a .sav file

Hi everyone,

after i upgraded to the new version 4.15.0 there are a view problems.

In editor standalone the steam achievements work as expected. But if package the game and play it over steam, no achievement will unlock. I tried everything. Reinstall the engine, disable plugins, delete the folders saved/intermediate/builfs and so on. Even the deriv-cache.
The steam overlay works. But the the achievements wont. Only in standalone mode.

To this comes the problem that the 32bit exe of the game not work. It starts and hang in taskmanager with 12-14% cpu usage and 100-120 mb of ram. But tha game dont open. It shows only the splash screen forever. The 64bit works but with no achievements.

I switched back to 4.14.3 and all works just fine. It is the same project with no changes.

Could it be that this is a bug in the engine? I need the 4.15.0 because 4.14.3 have the sound loading bug. Can any one from epic help? I have next week the release of my game.


I tried more now, but i have no luck. I tested with the devid 480 and Event that is not working on a shipping build. I doesn’t matter what i’m doing. Download the game from steam, starting from Build Folder, set the steam_appid.txt or not.

The Steam overlay work as expected: Name, Game Title, Name of Achievements.
But they will do not unlock.

Does anyone know what the Problem is? I Need realy help on this.

Sorry for bumping this up:

Is there any one who can help me? I searched now for over 9 hours and can’t find the Problem.

I made a blank Project that uses my steam app id. And there i can unlock the achievements. But not in my Project. I looked into my defaultengine.ini, changed everything to empty, uses only the Minimum Installation and so on.
The overlay works. But i can’t unlock the achievements.

One Thing that i found is: If i package the game in 4.15 the achievement (one over a key) works only in the main menu, but i don’t have to click any button or something. If i click first on the menu and try to use the key, nothing happens.

But every Level uses the same Settings (game mode, Player, etc.).

What uses the standalone window to use steam what my game not have. And, two or three weeks ago, all worked just fine. Without any Problem.

So after reading, searching, Debugging for over 20 hours i found the Problem.

Here is what i found out if someone came around this Problem:


Steam achievements work if you start your Level in standalone mode. But after you package your game and start over your menu the achievements don’t work anymore.


I found out that in my case, if i start the Level, all works fine. But then, if load my main menu and start a new game then all achievements are broken.

  • What happened:
    For some reason my current Player (singleplayer) lost the Connection to steam. The only message i get was: invalid Player state.

  • Why this happend and solution (for my case):
    I called a view functions (blueprint) in my main menu when you click start new game. Things like clear the Gameinstance and reset all values for Player and so on. Then i open the Level with “openlevel”. After that i read if a savegame exists for some stats. If true, then delete this.

You have to call “openlevel” as last node. Otherwise your Connection or whatever is broken.

I came to that conclusion because if i start the Level and all works fine and use over the console “openlevel” alls works fine too.

If anyone have the same Problem, this might be the solution.

Edit say:

It is not only that, that i have called open Level not as the latest node…

In my case, if i delete during the Level load or after the Level load my stats.sav, then no achievements work.
I guess this is a bug, or maybe something like anti-cheat. But i don’t have VAC enabled. Strange Thing…