Download

4.14 iOS provision not being found

When packaging my game for distribution on iOS, the provision and certs are not being found and just result in an unsigned message.

I have tried every solution I could find and nothing is working. I have deleted all my certs and provisions and started from scratch and ran through the tutorial in the documentation many times, tried renaming the files and editing the ini files. I have checked my bundle id and all my verifications and it says valid in the engine next to all of the certs and provisions, but will not build the game when I package.

I am building from source on a Mac, and recently updated to 4.14 from 4.12. It was working on 4.12, but will not work with in 4.14 now.

Is this a known issue?

I’ve seen other threads detailing similar things.

All I get are these messages,

Error Provision not found. A provision is required for deploying your app to the device.
Error Signing key not found. The app could not be digitally signed, because the signing key is not configured.

Try adding your certs for provisions for both development and shipping at the same time, and then try to package for shipping. I’d give that a 50/50 chance of helping you out. There’s lots of bad logic in the iOS/tvOS pipeline (especially on the tvOS side – my project has been blocked from tvOS distribution since Nov 26th as I have worked through bug after bug after bug blocking me).