4.14 delay nodes no longer respects custom time dilation

In 4.14, “Delay” and “Retriggerable Delay” does not take custom time dilation into account anymore. They still get the global time dilation but ignores custom time dilation. Timelines still work as previously, multiplying global and custom time dilation. This was tested in blueprints with parent class Actor.

Hi BeeHiveBob,

What you are seeing is by design, it was changed back in 4.9. You can find it listed in the 4.9 release notes.

Were you seeing the Delay node being affected by CustomTimeDilation in a version after 4.9?

For reference, here is another report of this.

Thanks a lot for the answer TJ Ballard,

Yes, I had no problem dilating Delay-nodes with CustomTimeDilation in 4.13.

My current work-around is now this


It works fine for most of my stuff. My only issue now is I can not dilate a Delay while it’s running.

Thanks again for telling about the 4.9 change, it cleared things up for me.

Same Problem here. This definitely came with 4.14.

Did you solve the problem in the end ?

Not really. I use the macro above to set the initial duration to count in CustomTimeDilation. But while the delay is running there is only GlobalTimeDilation able to affect it. In my case that is acceptable.
Since this is by design, I think making a new “Delay-node” as a macro works. The macro could be a Timeline and have a duration input, setting the timeline’s duration.

Yeah, I solved that with timelines as well, I’m not sure how performance heavy that is though, we’ll see I guess :slight_smile: