[4.14] Adding an entry in a custom struct breaks links

Hello folks,

I had this issue on 4.10 and hoped it got fixed with a later version.

Looks like it has not. I’m using 4.14.1 and the issue is still there.

I added an entry in my custom struct, kept working then restarted the editor to discover that every ref to that struct got broken.


This is the kind of errors I’m getting in the Logs

Is there anything to know to avoid this?


Oh wow, actually I just realized it also broke some structs that I didn’t modified !

Have you tried renaming the struct(s) and then cleaned up all redirectors (from the right-click-menu)?
I had a similar problem and I believe it was solved doing something like that, after which I could rename the struct back to its old name (and clean up redirectors again).

After which I think I had to restore ALL affected blueprints from a backup to have them reference back to the original struct asset names afterwards (since otherwise they will still try to reference the bad struct names) It was a bit of a hassle.

This could possibly help, but im not sure. You could give it a try, and always keep many backups.

Best Regards

I have a similar semi-fix : moving the struct in a different folder.

It usually breaks the endless loop where every time you open the editor it would break every ref.

But that doesn’t solve the problem entirely, it’s still prompt to error if I change the struct. Even after the above trick.