4.14.1 Editor freezes when lauching a Standalone Game

My issue is probably similar to this one, but I’ve not noticed it prior to testing in 4.14.1 Editor Crashing When Using Standalone Game - Platform & Builds - Unreal Engine Forums

When I launch a Standalone Game (from the menu bar along the top of the viewport), the game launches fine, but when I quit and return to the editor it’s completely unresponsive and frozen (the editor is). Checking task manager seems to show the process is still running, but the interface is completely locked up. (Interface icons, such as the ‘look here’ pulse ring is shown frozen in mid-pulse)

This happens in my own project, and in newly created C++ template projects.

Steps to reproduce -
Create a C++ First Person Template based project.
Launch the editor
Use the drop-down menu on Play to select Standalone Game.
Play then quit game.
Editor is now frozen.

I’m currently developing in 4.13.2, and am desperate to upgrade my project to 4.14 to get some of the audio fixes, but I’m stuck on the older version until I can be sure 4.14 is properly stable. Engine updates during the holiday season aren’t the best…

Just a note, the editor freezes the exact moment the grey ‘launch box’ appears for the new game process.
Suspecting something NVidia Driver related?, I’m currently on 376.19 if that helps.
970GTX card.

Hey Gavin1969,

I was actually experiencing this issue on my own machine here, and it seems to be fairly common with 4.14 and Nvidia’s GeForce Experience. What is happening is the engine gets caught in some type of loop when you run Standalone mode and have the ‘Share’ setting enabled within GeForce experience.

UE-39240

All you should have to do is turn off the ‘Share’ setting and the freezing will go away. Let me know if you have additional questions or need further assistance.

Thanks,

Andrew Hurley

OK, thanks for the tip. Would be good to get a fix asap though, scheduled for 4.16 is a bit of a shocker!!

And to further note, if you turn off Share while UE4.13 is open, it freezes too…
(so save your work before trying the above!) :frowning:

I have same problem with UE4.12.5 too. So disable ‘Share’ in Nvidia experience. then fix it.