4.13 Particle mesh rotation broken on Epic assets

I recently updated from 4.11 to 4.13 (so it may have started in 4.12) and I noticed that the birds_circling particle systems no longer function correctly. They are Epic assets, though I’m trying to remember which demo they came from. I’m guessing this also affected other particle systems.

The system spawns bird meshes that travel at a fixed radius and have a vertex shader to make the wings flap. The problem is that the birds all spawn in the same direction and no longer rotate along their flight path. This looks especially weird when the birds are flying sideways and their wings are alternating because the shader is supposed to move forward.

Here’s short video of the phenomenon. I enlarged the birds’ size to better show the effect.

Hi MXultra,

This issue seems to be very similar to this bug: Unreal Engine Issues and Bug Tracker (UE-36091)

A fix has been issued for 4.14, a possible work around is to change any value on the particle system and then re-save it.

Let me know if that resolves your issue, If not I will continue this investigation.

Ed Burgess

“A fix has been issued for 4.14”

thats… not good enough imho.
It should be fixed in 4.13 itself as its breaking a project soon to be released on steam, way prior to 4.14 being released.
Not to mention the time it will take to either edit the hundreds of particle effects or the time it will take to fix all the things that will break moving to 4.14 from 4.13.

The version that a fix is determined for is addressed by the developers. Unfortunately, I have no grounds to change the fix version or the severity of an issue. I’m sorry this issue is holding up a release but currently the only way to resolve it is via the workaround provided.

You can try the property matrix to change a setting on multiple assets (not sure if that will work) otherwise making a small edit to all of your particles is the only option until the fix is implemented.

Hi Ed, I tried the workaround but the problem persists.

After some testing I was able to reproduce this issue. It seems to be slightly different in the fact that it appears all the time and not after being cooked. If the 4.14 fix doesn’t address this issue I will put in a new bug report.

Hi MXultra,

The fix I posted earlier didn’t address this issue and it seems unique to this asset. I put in a report here:
Unreal Engine Issues and Bug Tracker (UE-36671)

Have you tried downloading a 4.13 version of mountain landscapes and migrating the asset from there? That may be a viable workaround until this is addressed.

Thank you for the finding this issue!

Ed Burgess

To follow up, the birds are still malfunctioning in 4.14.

It looks like the issue is that the mesh no longer rotates relative to its orbit.

Hi MXultra,

If you look at the public JIRA posted in my answer the issue is listed with 4.15 as the targeted fix version.