[4.13 p2] MediaTexture black on videos in Android 4.1.2

It worked everything ok in preview 1. But now, in preview 2, videos on Android 4.1.2 play, you can hear the audio, pause etc, but the MediaTexture keeps black. On 4.4 it’s still working, with visible video.

Tested both in my project as in a blank one. Using a material with a MediaTexture as a brush on Image widget, in UMG.

Hey RVillani,

Can you provide me with some screenshots of your set up and some steps to follow, as well as the device and its specifications so I can test this issue on my end?

Let me know if you have further questions or need additional assistance.


Of course, Andrew.

###The Android devices where the video is blank:

  • Samsung Galaxy 10.1 (GT-N8020) with Android version 4.1.2. Compilation number JZO54K.N8020UBAMD1.
  • Nexus 5 with Android version 6.0.1, version number MOB30Y.

###A device where the video is visible:

  • Samsung Galaxy Note 2014 with Android 4.4.2. Build number KOT49H.P605XXUCNE2.

###Steps to reproduce:

  • Create a FileMediaSource from a mp4 video placed in the Content/Movies folder.
  • Create a MediaPlayer from it.
  • Create MediaTexture and MediaSoundWave from the MediaPlayer.
  • Create a material with domain set to User Interface and use the MediaTexture as emissive.
  • Create a UMG, insert an Image in the canvas and set the material as it’s brush.
  • On the UMG graph, create two variables: MediaPlayer and MediaSoundWave. Set the previously created assets as its default values. On begin play use the MediaPlayer’s Open Source node to open the FileMediaSource asset and use the MediaSoundWave’s Play Sound 2D node to play the sound. The WorldContextObject can be Self, Player Controller or whatever. The result is the same.
  • On an empty level, on BeginPlay event, create a widget from the UMG class and add it to viewport.
  • Test it. On PC it runs fine. On Android the audio plays fine, but the texture keeps it’s Clear Color.

Images from my assets setup


Assets continued

Also, these are the GSpot prints using the two videos I tested with

Out of curiosity, I also tested setting the Clear Color of the MediaTexture to red. And the screen was red on the problematic devices. So the Material is rendering. And we have audio, so the video is playing. It’s just the texture that is not updating.

Here are my Android and Android SDK settings:

The problem presents itself no matter the build configuration (Shipping, Development etc) nor the texture compression settings (ETC1, ATC, Multi).

Thank you for your time, Andrew! Hope you guys can figure this out.

Hey RVillani,

Thanks for the clear and precise repro steps. I was able to confirm what you are reporting and have gone ahead and entered a bug report for the issue. You can track the issue following the link below on our new Public Issues Tracker.


Once the issue has been addressed by our engineers, the fix will be added to the release notes for fixed issues within an upcoming full engine or hotfix release.

Let me know if you have further questions or need additional assistance.


Thanks, Andrew! Also, just mentioning again because that’s where I’d start from: on preview 1 it worked. So, maybe, looking at the changes from 1 to 2 may help a lot. I’d try and help more, but after a year using the engine, I still haven’t had the time to study the source thoroughly.

UE-34898 has been fixed. Here is the GitHub commit for 4.13: link text

Thanks a lot, Chris! I’ve tested it in my project and it is working flawlessly! =)

I have the same problem in UE4.19.2. Do you know how to fix it? I have a h264 mp4 video and checked the paths. On Android black screen with audio. On PC video and audio.

same as ERuts, did you solve this?