Download

[4.13] How does the new media player work in 4.13?

I’m having trouble to figure out how to play local content in 4.13 it seems like it’s changed quite a bit.

In the input for enter a url for media source if I use the 4.12 path of: ./Movies/SAM_100_0065.mp4
and I get “Warning: Failed to open media file: ./Movies/SAM_100_0065.mp4”

This file played fine in 4.12
Would appreciate any tips as was looking forward to trying out the supposed 4.13 android media player framework improvements :slight_smile:

Additionally: Unfortunately youtube streaming still does not seem possible. I entered the embedded URL and received the following:

LogWmfMedia:Warning: Failed to finish resolve YouTube The byte stream type of the given URL is unsupported.

EDIT: I managed to get my local file working with an absolute path but this won’t work for android obviously. Which path should be set for android that also preferrably works on windows so you can test it?

I think the best solution is to roll back to 4.12.

I let others be the guinea pigs now and wait until they do the hotfixes and other people get their projects broken. One example; In 4.10 I could navigate UMG’s with a gamepad, it’s been broken since 4.11 with an ugle dotted line around the widgets and the input stolen. Not all of the changes are improvements.

Hi @aussieburger:

The movie sources have been dereferenced in 4.13. You now create a File Media Source, Media Playlist, or Stream Media Source. These now contain the filenames or URLs. Use the Media Player Open Source or Open Playlist to set the asset on the media player object. Or, you can use Media Player Set URL to point to a string (with scheme prefix, like file:// or http://).

NOTE: I just fixed a bug in preview 1 with movie playback on Android 4.4.x. It is fixed with this GitHub commit: https://github.com/EpicGames/UnrealEngine/commit/102ff1c3b0f5bf43a6a17c4afd5460f881279a95

Since this is a Java file update you can just replace the file in preview 1.

Is media playback or video playback working on the mac yet or not? gmpreussner said he was working on it last week?
55aa365d28b9d77c90360ac74acb02083ade6986.png

Mac is being working on right now for 4.13. Expect it in a later preview.

Very interested in the fix for the media player on Mac. Is there any work around to have a video texture play in mac project for ios?

yay!!! So excited

Chris spoke too soon - while Mac & iOS Media support is being worked on there is currently no guarantee that it will be complete for 4.13.

Uuuuh, no!

I know right, Ive been waiting forever for this to finally come out on mac, the waiting is killing me too :stuck_out_tongue:

under playback in the ‘File Media Source’ there is a default player field. It is blank and blank says the engine will choose the player automatically. I am getting an error when I try to open it in a ‘Media Player’ asset. the error sayd “Could not find a native player for file …”

What should I do to fix this?

If it couldn’t find a native player then the file extension wasn’t recognized. The ones handled are in AndroidMediaFactorModule.cpp.

I also didn’t find a path that worked for both. But I believe it’s intended behaviour that URLs are absolute. You see, for local files there’s the File Media Source. Then you pass it to the Open Source node of the Media Player.

Great work, Epic! One day I’ll make a list of all the things that make me say “I love Unreal”. The fact that I’m on a deadline with a project that depends on video on Android and, in 4.13, I’ve managed to make it work on the packaged game is one of those things. I just applied the fix in the .java file from Chris and everything worked.

With a bit of luck an initial AVFoundation implementation will now make it into 4.13 for Mac/iOS/tvOS with any necessary improvements to follow in future releases.

Whooo! good news.

Which steps to apply different video textures to different objects and let them play at the same time? Before was quite straightforward, now it’s not the same :confused:

What are you trying to accomplish? You can use two media players (each with own video texture and material) and assign them to a file source, then send Play to both.

Hmm…I’m missing something here.

Can anyone point out what I am doing wrong? This is in beginplay in the level blueprint. (for now)
I have tried .wmv, .mp4, .avi, .mkv none of these play.

The ‘Open Source’ returns true, the ‘Play’ returns false. The ‘wallPlayer’ variable should be filled with good default asset/value.
The Media source itself is pointing to a .wmv on disk that played well before (4.11).

(im on win8.1 btw)

EDIT: scratch this! I got it to sort of work. -> https://forums.unrealengine.com/showthread.php?122664-how-to-import-and-play-audio-and-video-files-on-UE-4-13&p=595422&viewfull=1#post595422

mediaplay.png

When I use the Media player playlist and set a different index in the playlist it appears that the media player goes to black and than plays that new index so I can’t get a smooth transition from one video to the next without having a second of no video playing?

Thanks!

Thanks!! i was getting mad xD