4.13 Black Landscape issue

**When i add material on the heightmap , map turned is black color. Would you help for me about that ? Btw this material working on UE 4.12. vers. **

Hi FeuerFreiS,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this on my end?
  • Was the heightmap imported via the landscape create menu or is it solely in the material?


1- its blank project and no additional content.

2- check in attechments file. ( Heightmap Scale : X : 2000 , Y : 2000 , Z: 400)

3- this heightmap imported via the landscape create menu.

This is expected. Your landscape has nothing painted. 4.12 and before had a bug where landscape with no layers painted would render using the preview weights from the material editor instead of accurately reflecting what the landscape would look like with nothing painted (which is typically black, although it can be different for user materials).

If you paint on your landscape you will get your layers. If you right-click on one of your layers in the landscape editor paint mode you will find a “fill” option which is a quick solution. Alternatively if you assign the material and layers before you create the landscape it will automatically fill the first layer.

Same problem here, please notice i’m using a splatmap to mask the various texture, it seems it’s the same technique FeuerFreiS uses.

Creating the Landscape after the layered material, i get a white landscape, but no textures and no masking.

Can submit example project if needed.

See the answer below.

So do we have to hand paint the landscape now? I still can’t get it to work with a splatmap.

How are you importing your weightmaps?

You should be able to import them in two ways: Through the import tab when you’re creating a landscape, and by right-clicking on a landscape layer and selecting “Import…”

I’ve just noticed the original question includes images of the material, where a three-colour layer map is fed into the “height” inputs of landscape layer blend nodes. This isn’t how it works! Height blending is an advanced mode for blending materials to preserve “high” details, like whole rocks, by using a per-texture heightmap which is white around details you want to preserve (like rocks) and black for the background (dirt). It’s not an input for a weightmap.

Turn off height blending, import each of your layer weightmaps as individual grayscale pngs one into each layer through the landscape editor.

See the docs: Creating and Using Custom Heightmaps and Layers in Unreal Engine | Unreal Engine 5.1 Documentation

Thank you. This did worked for me

This is still happening in 2021 with 4.27.1. Just following the “Landscape Essential Concepts” course on the Unreal Learning Hub and painted with the basic included material, everything appeared fine, then opened the project today and the landscape is black. Removing the landscape material allows the landscape to show the default world grid material, but as soon as you add the material again, it goes black again. My concern is what might happen if I attempt to seriously paint my game’s landscape… will all the work suddenly be lost one day when Unreal decides to exhibit this bug? Any advice on restoring the existing paint data would be appreciated! Thank you.

While there may be other scenarios when a landscape may appear black (see other answers above), I thank the Lord God for showing me a workaround for this annoying bug. The test landscape painting I did yesterday looked fine, but today showed up as solid black. After filing a bug report (it seems this black landscape issue has been around since 2015 at least), I discovered that by recreating the landscape material WITHOUT using Material Functions, I was able to see the landscape material again, and all my painting from the previous day was still preserved in the Layer Info assets.

Hopefully that issue won’t reappear in the future, but if it does, at least you can know that your painting isn’t lost, even if you can’t see it, and you might just have to re-set up the material without the use of Material Functions to get that invisible data back.

EDIT: To confirm your data is still there, you can switch to Unlit viewmode and you should be able to see your paint work.