4.13 and Widget Interaction problem (can't press widget button)


First of all sorry if this is in wrong subforum, feel free to move it if its so.

So, with the 4.13 I found out that a good bunch of my Widgets have stopped functioning properly. I found answers to this, followed the tutorials under:(https://docs.unrealengine.com/latest/INT/Engine/UMG/UserGuide/WidgetInteraction/) and

Nevertheless, the problem persists. Interaction source is set to mouse correctly in the widgets. Hovering over button works but clicking them does not function at all. I am completely at loss with this, how can I get widgets working once again? Anyone had similar issue?

I have set the below blueprint correctly also:

Hey there,

4.14 here, just bumping into the same problem, hovering works well, clicking/pressing won’t.
I tried as much combos as i could think of, followed tutos, googled, couldn’t find the right one.

Cheers !

try to start a question/bug report into AnswerHub, in that place you have more probability to receive an answer. probably is a bug, I have the same issue but I’ve found a glitch for solve teporary this issue, when you launch the project for test it simply focus something different (open web browser, a folder on windows, anything action that remove focus from unreal engine is good) and return on your running test (just a clarification sometime you need to repeat this 2/3 times, yes don’t work for sure this glitch but better than nothing XD)

Also had the same Issue. Solved it not with the “Press pointer Key” function.
On the Blueprint Component where i added the Widget, i set the “Receive Hardware Input” on the Widget Details to True.

Hope it helps someone

Yes, it works, thanks!
To interact with 3D widget actor you should check “receive hardware input” in the 3D widget component.


i guess it’s just another Linux issue…

nope, w11 4.27.1 - same

ticked in 5.0 but widget is still unclickable


my bad ~____~