4.13.2 rsync error

Hey there,

I am working on a windows 10 machine and I am remote building on a mac.
A few days ago I updated the engine to 4.13.2 and I now cannot remote build anymore.

I get the following errors:
UATHelper: Packaging (iOS): UnrealBuildTool: dup() in/out/err failed
UATHelper: Packaging (iOS): UnrealBuildTool: rsync: read error: Connection reset by peer (104)
UATHelper: Packaging (iOS): UnrealBuildTool: rsync error: error in rsync protocol data stream (code 12) at /home/lapo/packaging/rsync-3.0.4-1/src/rsync-3.0.4/io.c(791) [sender=3.0.4]

It worked fine back on 4.13.1 and I don’t know how to fix this. I have already checked if the ssh connections has an issue but the error happens after the connection is established.

Is this a known issue or is this just on my end?
What can I do to fix this?

-Joey

DJ_Joey,

Please upload your full error output logs.

Thanks!

Hi, this is the output log of the editor: (error happens on line 34)

If I try to generate a new ssh key for the remote connection it also fails with the same error when trying to copy the key from the mac to my pc via rsync.

-Joey

Hey DJ_Joey,

Could you send me a screenshot of your Platforms-iOS screen in your project settings? Everything except for the icons would be great.

Also, have a look at this thread to double check that you’ve set everything up correctly: Windows -> iOS Rsync/Remote Build Guide (4.8) - Mobile Development - Unreal Engine Forums

Thanks

Hi,

Here are the screenshots:

I will look through the thread as soon as I have time and then I will post here again, but as I said, the whole process worked before - so I really dont know why it doesn’t anymore. Even the ssh connection works, only the rsync stuff doesnt work.

-Joey

Sorry for the delay. I’ll actually need to take a look at your Bundle information, so if you don’t want to share it publicly could you PM me the screenshots through the forums without those sections blocked out?

https://forums.unrealengine.com/member.php?160394-Sean-Flint

Thanks for the additional information.

Could you verify that Engine/Extras/ThirdPartyNotUE/DeltaCopy exists.
DeltaCopy path exists and contains Binaries, Source, DeltaCopy.tps and DeltaCopy_License.txt?

Also is the project that you’re working in a project that you’ve upgraded as well? If so, could you try a project that is newly created in 4.13.2 and not upgraded from a previous version?

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

Hi Sean,

sorry that it took me so long to reply, it was very stressful the last few weeks.
Good news is the problem looked like it solved itself by updating to 4.14

Thanks for the help.
Best regards, Joey