4.13.2 Extremely Annoying Anim_BP BUG

Hi, i have upgraded my project from 4.11 to 4.12 and then to 4.13 final version. After this whenever i am in the character’s animation blueprint and i try to switch from the default SK_Mannequin to my Adobe Mixamo created character, it switches it but puts it in the Reference Pose T. This only happens in the Animation BP. When i open an animation in standalone persona i can change the mesh without any problem.
Looking forward to your reply!

Yes tried this and no change.

Did you tried to recompile your animation blueprint?
T Pose is visible in anim blueprint when there are some errors.

Another thing can be wrong animations. Can you check that all animations in your anim blueprint are retargeted to your new ?

I am using the default UE4 mannequin, so the mesh is targeted to this one. I will check it but judging by any animation in the anim_BP which is properly playing in the game, i don’t think there is an animation yet to be retargeted, but i’ll recheck them.

Try to set a new preview mesh/ preview anim? (Not sure if this is an option available in 4.13) Problem with retargeting, no preview mesh - Character & Animation - Unreal Engine Forums

Hey Xanadron,

Apologies for the confusion, but I’m having trouble understanding what the problem is. I think you’re referring to the fact that the Mixamo character is in a T Pose and the Mannequin is A pose. This is just the base pose for Mixamo characters. I’m not sure exactly what the problem is here.

Hi Williams,

I’ll try to explain it again, first of all, this never happened to me until i have upgraded the project from 4.11 to 4.12 and then to 4.13. Also this happens with any mesh.

1.When i am opening my Anim_BP it shows the default SK_Mannequin (it’s not a problem but i would like to know if i can change this default)

2.While i am in the Anim_BP and i am choosing a different mesh, in my case a Mixamo one, it changes it without any problem and it is playing any animaion when tweaking values from ‘‘Edit Preview’’ section in Anim Graph.

3.When i am in my Anim_BP with the Mixamo mesh chosen and i try to open an animation/blendspace (for example the IdleToRun blendspace) from the Anim Graph it opens it in the Anim_BP but the mesh (Mixamo) is in T Pose and i can see the timer going off, which probably means that it is playing but the mesh isn’t performing.

4.If the Anim_BP is not opened or tabbed and i open an animation from the content browser it opens in Persona showing the default SK_Mannequin, but this time i can succesfully change to any mesh, and it is perfomring the animation

What was the method you used to get the mixamo character and mannequin to share the same ? Did you assign the Mixamo Mesh to the Mannequin or the Mannequin Mesh to the Mixamo ?

I’m trying to recreate the content setup that you have, which is the important part of reproducing this.

I have assigned to the Mixamo mesh the original SK_Mannequin . The first one created with the Third Person template.

Can you send me an example project with this? I’d like to see if it’s a bug or not. You can PM me a download link on the forums.


The project is over 50 gb and even if i was to create a playable example, there would have been too many broken links. I am going to send you clean project with the Mixamo mesh/ and the default SK_Mannequin.

I opened your project and it’s just the two separate skeletal meshes with their own skeletons. If you create an AnimBP on the Mannequin, you cannot assign the Mixamo character since it’s using a different . I decided to retarget the Mixamo character (even without changing the ref pose) to the Mannequin so that I could assign it. I’m still not seeing this at all.

I don’t know what we are missing here.


Any news?

Right now, the project you sent me doesn’t have anything clearly reproducible. I tried getting this to reproduce without any luck (as noted in my last comment). If you have an AnimBP that this is occurring on, please migrate it in and include that in the project. I apologize that I didn’t ask for that specifically in my last comment, but I was trying to say that I cannot reproduce the issue with what you sent.

Currently solved by upgrading the project to 4.14. I think the problem came from meshes retargeted to the same (over 10 meshes with less or more bones). I am still confident that this will happen under these circumstances.