4.13.0 Landscape Crash

I’m getting a crash when trying to paint on a landscape in 4.13.0 (github). Repro steps:

Copy the content from the landscape mountains demo into a 4.13 project.

Make a new landscape and give it the materials from that demo.

Open the master material of those instances and change it to masked. Plug Landscape Visibility into the opacity mask. Compile and save material.

Set the landscape’s hole material to the same instance as its regular material.

Go into landscape mode and switch to the paint tab.

Crash happens.

Can anyone repro this for me so I can confirm its not something on my end?

Hi, this was a bug but it was fixed about a week ago in this commit:


I recommend pulling the latest 4.13.0 code from GitHub fairly often as we’re continuing to fix issues up until release.

  • Jack

Well, I just compiled a fresh download from github and I still get a crash.

Fatal error:
[…\Engine\Source\Runtime\Engine\Private\Materials\MaterialShared.cpp] [Line: 1829]
Couldn’t find ShaderPipeline for Material Resource M_Landscape_Master!

Hi, sorry about that! I see we also failed the verification and re-opened that ticket. I’ll post back here when it’s fixed; it should be some time overnight.

  • Jack

Sorry for not getting back to you. This was fixed in release 4.13, this is the commit:


I’m working off of the 4.13 branch and still have this problem. This on top of duplicate landscape error, its getting a tad frustrating.

Here’s some bit from the log:

[2016.09.12-05.05.00:822][283]LogWindows:Error: Couldn't find ShaderPipeline DepthPipeline for Material Resource FarmTerrain!
[2016.09.12-05.05.00:822][283]LogWindows:Error: 		With VF=FLocalVertexFactory, Platform=PCD3D_SM5
[2016.09.12-05.05.00:822][283]LogWindows:Error: 		FDepthOnlyPS Freq 3, ShouldCache: Mat=0, VF=1, Shader=1
[2016.09.12-05.05.00:822][283]LogWindows:Error: 		MaterialUsageDesc: LightingModel=MSM_DefaultLit, BlendMode=BLEND_Masked, SpecialEngine=0, TwoSided=0, TSNormal=0, Masked=1, Distorted=0, WritesEveryPixel=0, ModifiesMeshPosition=1, Usage={bUsedWithStaticLighting}

I’m taking a look. Thanks for the log, it’s very helpful.

Hi I have a bug that is tangential (shader compile cleanup concerning landscape paint materials) to this and is awaiting moderator approval to post here. I can’t see it in my questions, but I would like to have it added as I too would like to have this problem solved.

Are you using the “Early Z pass” project rendering option?

FYI: You don’t need to assign the hole material, it’ll automatically use the base one.

You also don’t need to set the material to masked, landscape automatically overrides the blend mode to masked when it automatically creates the hole material now. If you leave it as opaque you’ll get slightly better performance in areas without holes.

This should be fixed for 4.13.1.

The fix is here if you want to apply before then:


Hello, when is 4.13.1 scheduled for release?
We have the same issue and it’s holding back production :frowning:
The artists don’t work with compiled version.
Thank you!

Currently early next week (probably Tuesday), unless anything major comes up in testing.