4.12 Editor Crash when try to read my BlueprintCharacter

Since I’ve updated my project (full blueprint) with the last 4.12 version i’m unable to read in anyway my blueprint character (by trying to open it, right click on it or simply reading another actor connected to it) the editor immediately crash, I’ve tried migrate the blueprint with his dependencies from my working 4.11 project to a blank 4.12 project but the crash still occures…
Thanks in advance and sorry for my bad english

.LOG file
.DMP file

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you try deleting the saved and intermediate files before upgrading and let me know if this helps?

I have tried your suggestion about deleting the saved and intermediate files before upgrading but it doesn’t change anything.
As I’ve said before i have already migrate the blueprint and his dependencies in a clean 4.12 project but i can’t do anything for isolate the problem because the editor instantly crash when i click on one of these assets…
And i can’t remade my character from scratch in a clean project because i’m working on it since two years and i’ve integrated some very complex things (some preview of this character)

It sounds like i will be unable to upgrade this project

After looking over the log I noticed that you have a few errors.


LogBlueprint:Warning: Compiler Warning Clear Timer by Handle is deprecated; Use Clear and Invalidate Timer by Handle. Note: you no longer need to reset your handle yourself after switching to the new function.


Could you try making the changes suggested in the error message before upgrading? It looks like the issues can be found here /Game/Blueprints/MyCharacter_l.MyCharacter_l

Could you make these changes and send me an updated log if the project still crashes?

Also could you please provide the full callstack that is given by crash reporter when the editor crashes?

I have made these change before upgrading but it doesn’t change anything, even with the last hotfix. I haven’t any crash reporter, editor simply shutdown after freezing during a few seconds.
This is the .LOG of the full converted project and this one .LOG for a clean project where i have migrated the character and his dependencies.

Hello ,

As a quick suggestion, could you try updating to the new 4.12.2 hotfix and let me know if this helps with the issue that you are seeing on your end?

Done, but it doesn’t change anything :frowning:

Hello ,

Would it be possible for you to provide a simplified version of your project so that I could take a closer look? If you would like to provide it privately, you could do so by zipping it down and providing a me a dropbox or google drive link in a private message on the forums.

Hello ,

After digging through your character and running several tests, I have found that you are getting a stack overflow. If you disconnect your event tick before upgrading your project you will be able to open the character blueprint in 4.12 (it may take a few minutes to open the blueprint for the first time). I would suggest trying to break down the current blueprint that you are using into multiple blueprints. As a test you could try disconnecting all but 10 of the pins in your large sequence (in the event graph) coming off of tick and try compiling (you can reconnect the event tick after opening the blueprint in 4.12). This may compile without crashing. However, as you reconnect more pins to the large sequence (the sequence with 26 pins) you will notice your project crash on compile. I hope that this information helps.

Thanks for taking time to look at this, unfortunately i have spend all the day to try solving this issue, by reduce the main sequence to only 1 pins (26 before) and no using sequences that have more than 3 or 4 pins but it doesn’t work. It seems to happen when many things are connected together because each node are working alone. I really don’t understand why blueprint capacity has been reduced for 4.12 but i will simply keep working with 4.11 version…
Thanks for your help.

By the way, is there any chance to get a fix for this in a futur update?

Hello ,

I wrote a up report (UE-32305) for the stack over flow. It has been submitted to the developers for further consideration. I will provide updates with any pertinent information as it become available.

Make it a it a great day