Download

4.12.5 Dedicated server builds with 0 errors but will not run?

I haven’t encountered this problem before. Normally, errors crop up while building if I have something out of joint.

I am using Jenkins as an automated build system for both client and dedicated server. The client builds and runs without apparent error, but when I try to run the server (with -log or without) from the command line, I get no output and no error messages.

I spent several hours today doing web searches but did not find any post that had this same behavior and gleaned no suggestions on how to address this issue.

Has anyone seen this before?

Any advice on how to isolate the problem?

I am aware that there were issues with 4.12 and dedicated servers, though I did not dig into the relevant posts, but I was hoping that the irregularities had been resolved with .5.

I still haven’t successfully built a dedicated server with 4.12.5.

Can anyone tell me if they have?

I haven’t tried on 4.12.5 … will give it a bash tonight.

Have you tried just building a standard 3rd Person or 1st Person template version yet. Ensure that your build environment is correct and remove any “unknowns” from the equation. This might help you isolate whether it is a project, build environment, or UE4 issue.