4.12.2 Input problems, PIE session broken

Hi there!

I had a project that was working fine in 4.11.

When I tried switching to 4.12, I started having all sorts of trouble. I tested things on Win7/Win10.

  • The editor won’t pay attention anymore to “Game Gets Mouse Control” setting in PIE or standalone game.
  • Slate/UMG sort of breaks. Hovering on widgets breaks. If I press Shift+F1 in PIE, some widgets seem to regain hovering behaviour.
  • All sorts of race conditions and Heisenbugs. My player controllers SetupInputComponent() seems to fail; but I put a breakpoint there, they work fine.

I see similar issues in epic’s StrategyGame Example for 4.12. For example, panning the camera (swipe with left mouse press) doesn’t work when launching on PIE, and sometimes the HUD displays weirded glitches. The mini map won’t allow swiping. Sometimes pressing shift+F1 will fix these issues.

I tried Verify at the Epic Launcher, downloading 4,12 again, to the same results. Anybody else experienced these issues?

One more issue. I have a “landing” map that had a fixed camera in a scene, associated to an spectator pawn. The camera didn’t move or rotate in 4.11. In 4.12, this camera will move and rotate.

I got a workaround: if I call “SetupInputModeGameAndUI” with lock mouse unchecked in the level blueprint, everything works fine in 4.12.

Ok, this got marked as “answered”, but I don’t consider this a fix at all.

Can anybody explain what the underlying problem is? Or at least give me a hint as to how to figure it out?