4.11 Preview 4 Package for Win64 is failing cause of missing PhyX pdb files

“Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Failed to copy E:\Unreal4\Unreal Engine\4.11\Engine\Binaries\ThirdParty\PhysX\PhysX-3.3\Win64\VS2015\PhysX3PROFILE_x64.pdb to E:\Lucru\Unreal4\Cube\Saved\Sta
MainFrameActions: Packaging (Windows (64-bit)): gedBuilds\WindowsNoEditor\Engine\Binaries\ThirdParty\PhysX\PhysX-3.3\Win64\VS2015\PhysX3PROFILE_x64.pdb”

The packaging is failing. It fails from Editor and also when it runs from Unreal FrontEnd with the same message.

The build process complains that there are missing pdb files (PhyX ones in 4.11\Engine\Binaries\ThirdParty\PhysX\PhysX-3.3\Win64\VS2015) and they cannot be copied to the final build. I’ve chosen the option to install the engine without the extra Editor debug files. What I imagine happening is that indeed the pdb files are missing (they are not there because of the installing option at the start) yet I don’t get it why they are required since the configuration chosen was for Shipping. It doesn’t work by the way if I choose the Development configuration or restart the engine and try again or other combination.

I will probably have to download the extra 8 GB of debug files and have another go at it. Either way, this is an issue that probably needs to be solved because it makes no sense to have that option if you cannot build the projects without it.

Same issue here. Downloading the debug files, will report back.

Downloading the debug files fixed the build process. This wasn’t necessary in 4.10 thought.

Hello eudrea and ShortStuf7,

Thank you for reporting this issue. I gave it a try myself comparing 4.10.2 and 4.11 Preview 5 and saw the same issue only on 4.11. I’ve placed a bug in for the issue under the number UE-26830. In the meantime, the only workaround I could suggest would be to install the debugging symbols.

Have a nice day!

Yes, it’s only happening on 4.11. Thanks for taking into account, hopefully will get in in 4.11 initial release.

I’ve just verified a fix for this issue in one of our latest internal builds so the fix should be coming in an upcoming release, although I cannot be sure as to which version it will be.

This is still a problem for me in 4.11.1

Strange, it isn’t a problem in 4.11 for me anymore (the latest release version).

Hello Imsopov,

This should’ve been fixed with 4.11. Could you post the logs from when your packaging process fails? Also, have you tried downloading the debugging symbols temporarily to see if the issue is fixed for you? If not, then this may be a different issue.

I already installed them now I can launch fine. I’m not sure if the issue had to do. With me installing 4.11 with them included,i then uninstalled and reinstalled 4.11 again this time without because I wanted a fresh install because I was having issues with a project. The project would not launch so then I added the debugging symbols again and it worked fine.

Maybe if the project had been launched with them installed it can be run without? Just a guess. Either way project runs now

I’m having a similar issue on 4.14.3.

UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:5): C:\Program Files (x86)\Epic Games\4.14\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game Win64 Shipping -remoteini=“F:\Futureworks\YEAR TWO\XB2001\Assignment_03\TheHarbour” -
noxge -generatemanifest -NoHotReload. See logfile for details: ‘UnrealBuildTool-2017.04.13-15.07.47.txt’

Hello Thr3d,

Your issue doesn’t seem to be related. Your error message is the following:

[2017.04.13-14.01.25:438][808]UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: No modules found to build. All requested binaries were already part of the installed engine data.

This means that you’re including a plugin that requires you to be using a code project, although your project does not have any code added. To fix this you can either remove the plugin and the project’s dependency on it or you can add a blank code class through the File menu. Please note that the project will not be able to converted back to a Blueprint Only project after this and will require Visual Studio from that point on.

If you still need help with this issue, please make your own post since this post is quite old.